aboutsummaryrefslogtreecommitdiff
path: root/lang/rust/rust-host.mk
diff options
context:
space:
mode:
Diffstat (limited to 'lang/rust/rust-host.mk')
-rw-r--r--lang/rust/rust-host.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/rust/rust-host.mk b/lang/rust/rust-host.mk
index ede4baea1..acc93c521 100644
--- a/lang/rust/rust-host.mk
+++ b/lang/rust/rust-host.mk
@@ -3,7 +3,7 @@
# Copyright (C) 2023 Luca Barbato and Donald Hoskins
# Rust Environmental Vars
-CONFIG_HOST_SUFFIX:=$(shell cut -d"-" -f4 <<<"$(GNU_HOST_NAME)")
+CONFIG_HOST_SUFFIX:=$(word 4, $(subst -, ,$(GNU_HOST_NAME)))
RUSTC_HOST_ARCH:=$(HOST_ARCH)-unknown-linux-$(CONFIG_HOST_SUFFIX)
CARGO_HOME:=$(STAGING_DIR_HOST)/cargo