aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python3/files
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python/python3/files')
-rw-r--r--lang/python/python3/files/config.site13
-rw-r--r--lang/python/python3/files/python3-package-ctypes.mk2
-rw-r--r--lang/python/python3/files/python3-package-readline.mk2
3 files changed, 2 insertions, 15 deletions
diff --git a/lang/python/python3/files/config.site b/lang/python/python3/files/config.site
deleted file mode 100644
index 65c2d9585..000000000
--- a/lang/python/python3/files/config.site
+++ /dev/null
@@ -1,13 +0,0 @@
-#! /bin/sh
-#
-# Copyright (C) 2007-2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-ac_cv_file__dev_ptmx=yes
-ac_cv_file__dev_ptc=no
-ac_cv_buggy_getaddrinfo=no
-ac_cv_header_uuid_h=yes
-
diff --git a/lang/python/python3/files/python3-package-ctypes.mk b/lang/python/python3/files/python3-package-ctypes.mk
index 90e8cefed..e1bac47cd 100644
--- a/lang/python/python3/files/python3-package-ctypes.mk
+++ b/lang/python/python3/files/python3-package-ctypes.mk
@@ -8,7 +8,7 @@
define Package/python3-ctypes
$(call Package/python3/Default)
TITLE:=Python $(PYTHON3_VERSION) ctypes module
- DEPENDS:=+python3-light
+ DEPENDS:=+python3-light +libffi
endef
$(eval $(call Py3BasePackage,python3-ctypes, \
diff --git a/lang/python/python3/files/python3-package-readline.mk b/lang/python/python3/files/python3-package-readline.mk
index 4ce408db2..fbff134a3 100644
--- a/lang/python/python3/files/python3-package-readline.mk
+++ b/lang/python/python3/files/python3-package-readline.mk
@@ -8,7 +8,7 @@
define Package/python3-readline
$(call Package/python3/Default)
TITLE:=Python $(PYTHON3_VERSION) readline module
- DEPENDS:=+python3-light +libreadline +libncursesw
+ DEPENDS:=+python3-light +libreadline
endef
$(eval $(call Py3BasePackage,python3-readline, \