aboutsummaryrefslogtreecommitdiff
path: root/lang/python/pipx
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python/pipx')
-rw-r--r--lang/python/pipx/Makefile55
-rw-r--r--lang/python/pipx/test.sh5
2 files changed, 60 insertions, 0 deletions
diff --git a/lang/python/pipx/Makefile b/lang/python/pipx/Makefile
new file mode 100644
index 000000000..92835b76a
--- /dev/null
+++ b/lang/python/pipx/Makefile
@@ -0,0 +1,55 @@
+#
+# Copyright (C) 2023 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pipx
+PKG_VERSION:=1.2.1
+PKG_RELEASE:=1
+
+PYPI_NAME:=pipx
+PKG_HASH:=698777c05a97cca81df4dc6a71d9ca4ece2184c6f91dc7a0e4802ac51d86d32a
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_BUILD_DEPENDS:=python-hatchling/host
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/pipx
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Install/Run Python Applications in Isolated Environments
+ URL:=https://github.com/pypa/pipx
+ DEPENDS:= \
+ +python3-light \
+ +python3-logging \
+ +python3-urllib \
+ +python3-venv \
+ +python3-argcomplete \
+ +python3-packaging \
+ +python3-userpath
+endef
+
+define Package/pipx/description
+pipx is a tool to help you install and run end-user applications written
+in Python. It's roughly similar to macOS's brew, JavaScript's npx, and
+Linux's apt.
+
+It's closely related to pip. In fact, it uses pip, but is focused on
+installing and managing Python packages that can be run from the command
+line directly as applications.
+endef
+
+$(eval $(call Py3Package,pipx))
+$(eval $(call BuildPackage,pipx))
+$(eval $(call BuildPackage,pipx-src))
diff --git a/lang/python/pipx/test.sh b/lang/python/pipx/test.sh
new file mode 100644
index 000000000..a4f2348ae
--- /dev/null
+++ b/lang/python/pipx/test.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+[ "$1" = pipx ] || exit 0
+
+pipx --version | grep -Fx "$PKG_VERSION"