aboutsummaryrefslogtreecommitdiff
path: root/lang/python/numpy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python/numpy/Makefile')
-rw-r--r--lang/python/numpy/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/lang/python/numpy/Makefile b/lang/python/numpy/Makefile
index aaf940879..10a954da9 100644
--- a/lang/python/numpy/Makefile
+++ b/lang/python/numpy/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=numpy
PKG_VERSION:=1.23.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PYPI_NAME:=$(PKG_NAME)
PKG_HASH:=51bf49c0cd1d52be0a240aa66f3458afc4b95d8993d2d04f0d91fa60c10af6cd
@@ -23,6 +23,10 @@ PKG_CONFIG_DEPENDS:= \
PKG_BUILD_DEPENDS:=python-cython/host
+# Ensure numpy does not find openblas if openblas support is not enabled
+PYTHON3_PKG_BUILD_VARS:= \
+ $(if $(CONFIG_NUMPY_OPENBLAS_SUPPORT),,NPY_BLAS_ORDER= NPY_LAPACK_ORDER= )
+
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk
@@ -50,17 +54,18 @@ config NUMPY_OPENBLAS_SUPPORT
endmenu
endef
-ifdef CONFIG_NUMPY_OPENBLAS_SUPPORT
define Build/Prepare/numpy-sitecfg
echo "[DEFAULT]" > $(PKG_BUILD_DIR)/site.cfg
echo "library_dirs = $(STAGING_DIR)/usr/lib" >> $(PKG_BUILD_DIR)/site.cfg
echo "include_dirs = $(STAGING_DIR)/usr/include" >> $(PKG_BUILD_DIR)/site.cfg
+
+ ifdef CONFIG_NUMPY_OPENBLAS_SUPPORT
echo >> $(PKG_BUILD_DIR)/site.cfg
echo "[openblas]" >> $(PKG_BUILD_DIR)/site.cfg
echo "libraries = openblas" >> $(PKG_BUILD_DIR)/site.cfg
echo "runtime_library_dirs = /usr/lib" >> $(PKG_BUILD_DIR)/site.cfg
+ endif
endef
-endif
define Build/Prepare
$(call Build/Prepare/Default)