aboutsummaryrefslogtreecommitdiff
path: root/lang/php5
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile8
-rw-r--r--lang/php5/pecl.mk4
2 files changed, 6 insertions, 6 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 17314cfeb..9d02a2d29 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -491,10 +491,10 @@ define Build/InstallDev
mkdir -p $(PKG_BUILD_DIR)/staging/usr/bin
make -C $(PKG_BUILD_DIR) install INSTALL_ROOT=$(PKG_BUILD_DIR)/staging
rm -f $(PKG_BUILD_DIR)/staging/usr/bin/php
- $(CP) $(PKG_BUILD_DIR)/staging/* $(STAGING_DIR_HOST)
- sed -i -e "s#prefix='/usr'#prefix='$(STAGING_DIR_HOST)/usr'#" $(STAGING_DIR_HOST)/usr/bin/phpize
- sed -i -e "s#exec_prefix=\"\`eval echo /usr\`\"#exec_prefix='$(STAGING_DIR_HOST)/usr'#" $(STAGING_DIR_HOST)/usr/bin/phpize
- sed -i -e "s#prefix=\"/usr\"#prefix=\"$(STAGING_DIR_HOST)/usr\"#" $(STAGING_DIR_HOST)/usr/bin/php-config
+ $(CP) $(PKG_BUILD_DIR)/staging/* $(STAGING_DIR)/host
+ sed -i -e "s#prefix='/usr'#prefix='$(STAGING_DIR)/host/usr'#" $(STAGING_DIR)/host/usr/bin/phpize
+ sed -i -e "s#exec_prefix=\"\`eval echo /usr\`\"#exec_prefix='$(STAGING_DIR)/host/usr'#" $(STAGING_DIR)/host/usr/bin/phpize
+ sed -i -e "s#prefix=\"/usr\"#prefix=\"$(STAGING_DIR)/host/usr\"#" $(STAGING_DIR)/host/usr/bin/php-config
endef
define BuildModule
diff --git a/lang/php5/pecl.mk b/lang/php5/pecl.mk
index ee2a5ce77..88d3a98bb 100644
--- a/lang/php5/pecl.mk
+++ b/lang/php5/pecl.mk
@@ -15,11 +15,11 @@ endef
define Build/Prepare
$(Build/Prepare/Default)
- ( cd $(PKG_BUILD_DIR); $(STAGING_DIR_HOST)/usr/bin/phpize )
+ ( cd $(PKG_BUILD_DIR); $(STAGING_DIR)/host/usr/bin/phpize )
endef
CONFIGURE_ARGS+= \
- --with-php-config=$(STAGING_DIR_HOST)/usr/bin/php-config
+ --with-php-config=$(STAGING_DIR)/host/usr/bin/php-config
define PECLPackage