aboutsummaryrefslogtreecommitdiff
path: root/lang/luaposix/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/luaposix/Makefile')
-rw-r--r--lang/luaposix/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/luaposix/Makefile b/lang/luaposix/Makefile
index abc1e52bb..92ff86d0e 100644
--- a/lang/luaposix/Makefile
+++ b/lang/luaposix/Makefile
@@ -44,6 +44,9 @@ CONFIGURE_VARS += ac_cv_path_LDOC="true"
TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC) -std=gnu99
ifeq ($(CONFIG_USE_MUSL),y)
TARGET_CFLAGS += -D_POSIX_PRIORITY_SCHEDULING
+ # Musl doesn't do all of XOPEN_REALTIME, but it does for luaposix.
+ # see https://github.com/luaposix/luaposix/issues/295
+ TARGET_CFLAGS += -D_XOPEN_REALTIME=1
endif
ifneq ($(CONFIG_USE_GLIBC),)