aboutsummaryrefslogtreecommitdiff
path: root/ipv6
diff options
context:
space:
mode:
Diffstat (limited to 'ipv6')
-rw-r--r--ipv6/aiccu/Makefile2
-rw-r--r--ipv6/aiccu/patches/300-resolver-uclibc.patch17
-rw-r--r--ipv6/aiccu/patches/400-musl-compat.patch6
3 files changed, 8 insertions, 17 deletions
diff --git a/ipv6/aiccu/Makefile b/ipv6/aiccu/Makefile
index 0034c0b70..dae693839 100644
--- a/ipv6/aiccu/Makefile
+++ b/ipv6/aiccu/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=aiccu
PKG_VERSION:=20070115
-PKG_RELEASE:=13
+PKG_RELEASE:=14
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
diff --git a/ipv6/aiccu/patches/300-resolver-uclibc.patch b/ipv6/aiccu/patches/300-resolver-uclibc.patch
index 1a5f11626..b88ef5c1a 100644
--- a/ipv6/aiccu/patches/300-resolver-uclibc.patch
+++ b/ipv6/aiccu/patches/300-resolver-uclibc.patch
@@ -5,7 +5,7 @@
int getrrs(const char *label, int rrtype, void gotrec(unsigned int num, int type, const char *record))
{
-#ifdef _LINUX
-+#if defined(_LINUX) && defined(__GLIBC__)
++#if defined(_LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)
struct __res_state res;
#endif
unsigned char answer[8192];
@@ -14,7 +14,7 @@
uint32_t ttl = 0;
-#ifdef _LINUX
-+#if defined(_LINUX) && defined(__GLIBC__)
++#if defined(_LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)
memset(&res, 0, sizeof(res));
res.options = RES_DEBUG;
res_ninit(&res);
@@ -23,18 +23,7 @@
memset(answer, 0, sizeof(answer));
-#ifdef _LINUX
-+#if defined(_LINUX) && defined(__GLIBC__)
++#if defined(_LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)
ret = res_nquery(&res, label, C_IN, rrtype, answer, sizeof(answer));
#else
ret = res_query(label, C_IN, rrtype, answer, sizeof(answer));
---- a/common/dn_skipname.c
-+++ b/common/dn_skipname.c
-@@ -9,7 +9,7 @@
- * return:
- * 0 on success, -1 (with errno set) on failure.
- */
--int ns_name_skip(const u_char **ptrptr, const u_char *eom)
-+static int ns_name_skip(const u_char **ptrptr, const u_char *eom)
- {
- const u_char *cp;
- u_int n;
diff --git a/ipv6/aiccu/patches/400-musl-compat.patch b/ipv6/aiccu/patches/400-musl-compat.patch
index 2e732d8a2..b6e0c3236 100644
--- a/ipv6/aiccu/patches/400-musl-compat.patch
+++ b/ipv6/aiccu/patches/400-musl-compat.patch
@@ -20,10 +20,12 @@
#include <linux/if_tun.h>
--- a/common/dn_skipname.c
+++ b/common/dn_skipname.c
-@@ -1,5 +1,6 @@
+@@ -1,6 +1,8 @@
#include <errno.h>
#include <resolv.h>
-+#include <sys/types.h>
++#include <sys/types.h>
++
/* Ripped from glibc 2.4 sources. */
+ /*