aboutsummaryrefslogtreecommitdiff
path: root/admin/monit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'admin/monit/Makefile')
-rw-r--r--admin/monit/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/admin/monit/Makefile b/admin/monit/Makefile
index f6ab3a430..ae684f4a8 100644
--- a/admin/monit/Makefile
+++ b/admin/monit/Makefile
@@ -8,19 +8,18 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=monit
-PKG_VERSION:=5.26.0
-PKG_RELEASE:=2
+PKG_VERSION:=5.33.0
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://mmonit.com/monit/dist
-PKG_HASH:=87fc4568a3af9a2be89040efb169e3a2e47b262f99e78d5ddde99dd89f02f3c2
+PKG_SOURCE_URL:=https://bitbucket.org/tildeslash/monit/downloads/
+PKG_HASH:=1ace889c0183473a9d70160df6533bb6e1338dc1354f5928507803e1e2a863b5
-PKG_MAINTAINER:=Etienne CHAMPETIER <champetier.etienne@gmail.com>
+PKG_MAINTAINER:=Yaroslav Petrov <info@lank.me>
PKG_LICENSE:=AGPL-3.0
PKG_LICENSE_FILES:=COPYING
PKG_CPE_ID:=cpe:/a:tildeslash:monit
-PKG_FIXUP:=libtool
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
@@ -78,6 +77,11 @@ ifeq ($(BUILD_VARIANT),nossl)
--without-ssl
endif
+define Build/Prepare
+ $(Build/Prepare/Default)
+ (cd $(PKG_BUILD_DIR) && ./bootstrap)
+endef
+
define Package/monit/conffiles
/etc/monitrc
endef