aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/mstpd/Makefile2
-rw-r--r--net/mstpd/patches/010-bsd.patch17
2 files changed, 18 insertions, 1 deletions
diff --git a/net/mstpd/Makefile b/net/mstpd/Makefile
index f6c67dfed..a099f9932 100644
--- a/net/mstpd/Makefile
+++ b/net/mstpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mstpd
PKG_VERSION:=0.0.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/mstpd/mstpd/tar.gz/$(PKG_VERSION)?
diff --git a/net/mstpd/patches/010-bsd.patch b/net/mstpd/patches/010-bsd.patch
new file mode 100644
index 000000000..45ecb3f75
--- /dev/null
+++ b/net/mstpd/patches/010-bsd.patch
@@ -0,0 +1,17 @@
+--- a/hmac_md5.c
++++ b/hmac_md5.c
+@@ -356,10 +356,10 @@ caddr_t digest; /* caller digest to be filled in */
+ */
+
+ /* start out by storing key in pads */
+- bzero(k_ipad, sizeof k_ipad);
+- bzero(k_opad, sizeof k_opad);
+- bcopy(key, k_ipad, key_len);
+- bcopy( key, k_opad, key_len);
++ memset(k_ipad, 0, sizeof k_ipad);
++ memset(k_opad, 0, sizeof k_opad);
++ memcpy(k_ipad, key, key_len);
++ memcpy(k_opad, key, key_len);
+
+ /* XOR key with ipad and opad values */
+ for(i = 0; i < 64; ++i)