aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/banip/Makefile2
-rwxr-xr-xnet/banip/files/banip.init2
-rwxr-xr-xnet/banip/files/banip.sh2
3 files changed, 3 insertions, 3 deletions
diff --git a/net/banip/Makefile b/net/banip/Makefile
index 5cd5bcb9b..43a2c2ef4 100644
--- a/net/banip/Makefile
+++ b/net/banip/Makefile
@@ -6,7 +6,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=banip
-PKG_VERSION:=0.3.8
+PKG_VERSION:=0.3.9
PKG_RELEASE:=1
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
diff --git a/net/banip/files/banip.init b/net/banip/files/banip.init
index e9abfebad..c999c6b00 100755
--- a/net/banip/files/banip.init
+++ b/net/banip/files/banip.init
@@ -13,7 +13,7 @@ ban_script="/usr/bin/banip.sh"
ban_pidfile="/var/run/banip.pid"
if [ -s "${ban_pidfile}" ] && \
- [ "${action}" != "help" ] && [ "${action}" != "status" ] && [ "${action}" != "boot" ]
+ [ "${action}" != "help" ] && [ "${action}" != "status" ] && [ "${action}" != "boot" ] && [ "${action}" != "enabled" ]
then
exit 1
fi
diff --git a/net/banip/files/banip.sh b/net/banip/files/banip.sh
index 51345138f..c8639a9c6 100755
--- a/net/banip/files/banip.sh
+++ b/net/banip/files/banip.sh
@@ -13,7 +13,7 @@
#
LC_ALL=C
PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-ban_ver="0.3.8"
+ban_ver="0.3.9"
ban_basever=""
ban_enabled=0
ban_automatic="1"