aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/bridge-utils/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/net/bridge-utils/Makefile b/net/bridge-utils/Makefile
index 5a9cdb8af..7b9691cc9 100644
--- a/net/bridge-utils/Makefile
+++ b/net/bridge-utils/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=bridge-utils
PKG_VERSION:=1.5
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/shemminger/bridge-utils.git
@@ -49,4 +49,11 @@ define Package/bridge/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/brctl/brctl $(1)/usr/sbin
endef
+define Package/bridge/prerm
+#!/bin/sh
+$${IPKG_INSTROOT}/bin/busybox brctl -h 2>&1 | grep -q BusyBox && \
+ln -sf ../../bin/busybox $${IPKG_INSTROOT}/usr/sbin/brctl
+exit 0
+endef
+
$(eval $(call BuildPackage,bridge))