aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/openconnect/Makefile2
-rwxr-xr-xnet/openconnect/files/openconnect-wrapper30
2 files changed, 2 insertions, 30 deletions
diff --git a/net/openconnect/Makefile b/net/openconnect/Makefile
index 60953652c..ec2554c83 100644
--- a/net/openconnect/Makefile
+++ b/net/openconnect/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openconnect
PKG_VERSION:=7.08
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/net/openconnect/files/openconnect-wrapper b/net/openconnect/files/openconnect-wrapper
index 082dfba73..8a4ff78f9 100755
--- a/net/openconnect/files/openconnect-wrapper
+++ b/net/openconnect/files/openconnect-wrapper
@@ -10,32 +10,4 @@ test -z "$1" && exit 1
pwfile=$1
shift
-
-pidfile=/var/run/ocwrap-$$.pid
-
-cleanup()
-{
- if ! test -z "$pid";then
- kill $pid
- wait $pid
- fi
- exit 0
-}
-
-cleanup2()
-{
- if ! test -z "$pid";then
- kill -2 $pid
- wait $pid
- fi
- exit 0
-}
-
-trap cleanup2 2
-trap cleanup 1 3 6 15
-
-rm -f "$pidfile"
-/usr/sbin/openconnect $* <$pwfile &
-pid=$!
-
-wait $pid
+exec /usr/sbin/openconnect "$@" <$pwfile