aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/nginx/Makefile5
-rw-r--r--net/nginx/patches/102-sizeof_test_fix.patch2
2 files changed, 4 insertions, 3 deletions
diff --git a/net/nginx/Makefile b/net/nginx/Makefile
index 42f831ba0..58096185d 100644
--- a/net/nginx/Makefile
+++ b/net/nginx/Makefile
@@ -8,12 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=nginx
-PKG_VERSION:=1.10.3
+PKG_VERSION:=1.12.0
PKG_RELEASE:=1
PKG_SOURCE:=nginx-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://nginx.org/download/
-PKG_MD5SUM:=204a20cb4f0b0c9db746c630d89ff4ea
+PKG_HASH:=b4222e26fdb620a8d3c3a3a8b955e08b713672e1bc5198d1e4f462308a795b30
+PKG_MD5SUM:=995eb0a140455cf0cfc497e5bd7f94b3
PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
PKG_LICENSE:=2-clause BSD-like license
diff --git a/net/nginx/patches/102-sizeof_test_fix.patch b/net/nginx/patches/102-sizeof_test_fix.patch
index 36d7aaff4..8a0e88200 100644
--- a/net/nginx/patches/102-sizeof_test_fix.patch
+++ b/net/nginx/patches/102-sizeof_test_fix.patch
@@ -10,7 +10,7 @@
+ 'Y', '3', 'p', 'M', '\n'
+};
+
- int main() {
+ int main(void) {
- printf("%d", (int) sizeof($ngx_type));
+ printf("dummy use of object_code_block to avoid gc-section: %c", object_code_block[0]);
return 0;