aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/python/django1/Makefile2
-rw-r--r--lang/python/django1/patches/001-load-byte-compiled-db-migrations.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/lang/python/django1/Makefile b/lang/python/django1/Makefile
index c7d3bbcf6..db260a208 100644
--- a/lang/python/django1/Makefile
+++ b/lang/python/django1/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=django1
PKG_VERSION:=1.11.29
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=Django
PKG_HASH:=4200aefb6678019a0acf0005cd14cfce3a5e6b9b90d06145fcdd2e474ad4329c
diff --git a/lang/python/django1/patches/001-load-byte-compiled-db-migrations.patch b/lang/python/django1/patches/001-load-byte-compiled-db-migrations.patch
new file mode 100644
index 000000000..e347e5534
--- /dev/null
+++ b/lang/python/django1/patches/001-load-byte-compiled-db-migrations.patch
@@ -0,0 +1,11 @@
+--- a/django/db/migrations/loader.py
++++ b/django/db/migrations/loader.py
+@@ -106,7 +106,7 @@ class MigrationLoader(object):
+ # Scan for .py files
+ migration_names = set()
+ for name in os.listdir(directory):
+- if name.endswith(".py"):
++ if name.endswith(".py") or name.endswith(".pyc"):
+ import_name = name.rsplit(".", 1)[0]
+ if import_name[0] not in "_.~":
+ migration_names.add(import_name)