aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/tgt/Makefile6
-rw-r--r--net/tgt/files/tgt.config1
-rwxr-xr-xnet/tgt/files/tgt.init8
3 files changed, 10 insertions, 5 deletions
diff --git a/net/tgt/Makefile b/net/tgt/Makefile
index 3daa0eaed..5a72a2701 100644
--- a/net/tgt/Makefile
+++ b/net/tgt/Makefile
@@ -4,15 +4,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=tgt
-PKG_VERSION:=1.0.78
+PKG_VERSION:=1.0.79
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/fujita/tgt/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=3ba44d5195b2007c6d9008f46a10f7754c90b9bcf6117a7f3e136accb209faac
+PKG_HASH:=6736d799a202ff665549359859441c6d2b5e3425bffef9ee60ab5a101342a40d
PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
-PKG_LICENSE:=GPL-2.0
+PKG_LICENSE:=GPL-2.0-only
PKG_USE_MIPS16:=0
PKG_INSTALL:=1
diff --git a/net/tgt/files/tgt.config b/net/tgt/files/tgt.config
index e226f6586..069f59472 100644
--- a/net/tgt/files/tgt.config
+++ b/net/tgt/files/tgt.config
@@ -4,6 +4,7 @@ config options 'tgt'
option iothreads '2'
# option nop_count '3'
# option nop_interval '1'
+# option logging '0'
# list portal '[::1]'
# list portal '127.0.0.1:3261'
# list portal '0.0.0.0:3262'
diff --git a/net/tgt/files/tgt.init b/net/tgt/files/tgt.init
index c10057d65..04ee4931d 100755
--- a/net/tgt/files/tgt.init
+++ b/net/tgt/files/tgt.init
@@ -184,16 +184,20 @@ validate_tgt_section() {
'iothreads:uinteger' \
'portal:list(string)' \
'nop_interval:uinteger' \
- 'nop_count:uinteger'
+ 'nop_count:uinteger' \
+ 'logging:bool:0'
}
start_tgt_instance() {
+ local fg_flag=-f
[ "$2" = 0 ] || {
$logger "Validation failed for tgt options"
return 1
}
procd_open_instance
- procd_set_param command $PROG -f
+ procd_set_param command $PROG
+ [ "$logging" -eq 1 ] && fg_flag=-D
+ procd_append_param command "$fg_flag"
[ "$iothreads" ] && procd_append_param command -t "$iothreads"
[ "$portal$nop_interval$nop_count" ] && {
local iscsi="" i