aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/gnunet/Makefile2
-rw-r--r--net/gnunet/files/gnunet.init11
2 files changed, 3 insertions, 10 deletions
diff --git a/net/gnunet/Makefile b/net/gnunet/Makefile
index 58808c0f9..0dba1aefc 100644
--- a/net/gnunet/Makefile
+++ b/net/gnunet/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gnunet
PKG_SOURCE_VERSION:=35845
PKG_VERSION:=0.10.1-svn$(PKG_SOURCE_VERSION)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
# ToDo:
# - split into small packages
diff --git a/net/gnunet/files/gnunet.init b/net/gnunet/files/gnunet.init
index baecd9489..04b406771 100644
--- a/net/gnunet/files/gnunet.init
+++ b/net/gnunet/files/gnunet.init
@@ -5,7 +5,7 @@ START=50
STOP=10
USE_PROCD=1
-PROG=/usr/bin/gnunet-arm
+PROG=/usr/lib/gnunet/libexec/gnunet-service-arm
CONFIGFILE=/var/run/gnunet/gnunet.conf
start_service() {
@@ -19,14 +19,7 @@ start_service() {
fi
procd_open_instance
procd_set_param user gnunet
- procd_set_param command $PROG -c $CONFIGFILE -s -m
+ procd_set_param command $PROG -c $CONFIGFILE
procd_set_param respawn
procd_close_instance
}
-
-stop_service() {
- procd_open_instance
- procd_set_param user gnunet
- procd_set_param command $PROG -c $CONFIGFILE -e
- procd_close_instance
-}