aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/nail/Makefile2
-rw-r--r--mail/nail/patches/100-handle-openssl-without-sslv2-sslv3.patch (renamed from mail/nail/patches/100-handle-openssl-without-sslv2.patch)10
2 files changed, 9 insertions, 3 deletions
diff --git a/mail/nail/Makefile b/mail/nail/Makefile
index 541d203ce..addc0f4c6 100644
--- a/mail/nail/Makefile
+++ b/mail/nail/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nail
PKG_VERSION:=12.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=BSD-2-Clause
PKG_SOURCE:=heirloom-mailx_$(PKG_VERSION).orig.tar.gz
diff --git a/mail/nail/patches/100-handle-openssl-without-sslv2.patch b/mail/nail/patches/100-handle-openssl-without-sslv2-sslv3.patch
index 4352fe871..793bc3dc0 100644
--- a/mail/nail/patches/100-handle-openssl-without-sslv2.patch
+++ b/mail/nail/patches/100-handle-openssl-without-sslv2-sslv3.patch
@@ -1,6 +1,6 @@
--- a/openssl.c
+++ b/openssl.c
-@@ -216,9 +216,12 @@ ssl_select_method(const char *uhp)
+@@ -216,11 +216,17 @@ ssl_select_method(const char *uhp)
cp = ssl_method_string(uhp);
if (cp != NULL) {
@@ -10,7 +10,13 @@
- else if (equal(cp, "ssl3"))
+ else
+#endif
++#ifndef OPENSSL_NO_SSL3
+ if (equal(cp, "ssl3"))
method = SSLv3_client_method();
- else if (equal(cp, "tls1"))
+- else if (equal(cp, "tls1"))
++ else
++#endif
++ if (equal(cp, "tls1"))
method = TLSv1_client_method();
+ else {
+ fprintf(stderr, catgets(catd, CATSET, 244,