aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/xl2tpd/Makefile2
-rw-r--r--net/xl2tpd/files/l2tp.sh (renamed from net/xl2tpd/files/l2tpv2.sh)8
2 files changed, 5 insertions, 5 deletions
diff --git a/net/xl2tpd/Makefile b/net/xl2tpd/Makefile
index b99641c5f..2a1c4a5df 100644
--- a/net/xl2tpd/Makefile
+++ b/net/xl2tpd/Makefile
@@ -67,7 +67,7 @@ define Package/xl2tpd/install
$(INSTALL_DATA) ./files/options.xl2tpd $(1)/etc/ppp/
$(INSTALL_DIR) $(1)/lib/netifd/proto
- $(INSTALL_BIN) ./files/l2tpv2.sh $(1)/lib/netifd/proto
+ $(INSTALL_BIN) ./files/l2tp.sh $(1)/lib/netifd/proto
endef
$(eval $(call BuildPackage,xl2tpd))
diff --git a/net/xl2tpd/files/l2tpv2.sh b/net/xl2tpd/files/l2tp.sh
index 6466cf0be..867234dbe 100644
--- a/net/xl2tpd/files/l2tpv2.sh
+++ b/net/xl2tpd/files/l2tp.sh
@@ -8,7 +8,7 @@
init_proto "$@"
}
-proto_l2tpv2_init_config() {
+proto_l2tp_init_config() {
proto_config_add_string "username"
proto_config_add_string "password"
proto_config_add_string "keepalive"
@@ -20,7 +20,7 @@ proto_l2tpv2_init_config() {
no_device=1
}
-proto_l2tpv2_setup() {
+proto_l2tp_setup() {
local config="$1"
local iface="$2"
local optfile="/tmp/l2tp/options.${config}"
@@ -77,7 +77,7 @@ proto_l2tpv2_setup() {
xl2tpd-control connect l2tp-${config}
}
-proto_l2tpv2_teardown() {
+proto_l2tp_teardown() {
local interface="$1"
local optfile="/tmp/l2tp/options.${interface}"
@@ -103,5 +103,5 @@ proto_l2tpv2_teardown() {
}
[ -n "$INCLUDE_ONLY" ] || {
- add_protocol l2tpv2
+ add_protocol l2tp
}