aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/nginx/Makefile2
-rw-r--r--net/nginx/patches/400-nginx-1.4.x_proxy_protocol_patch_v2.patch11
2 files changed, 1 insertions, 12 deletions
diff --git a/net/nginx/Makefile b/net/nginx/Makefile
index 89a7ce99e..e93326e52 100644
--- a/net/nginx/Makefile
+++ b/net/nginx/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nginx
PKG_VERSION:=1.4.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://nginx.org/download/
diff --git a/net/nginx/patches/400-nginx-1.4.x_proxy_protocol_patch_v2.patch b/net/nginx/patches/400-nginx-1.4.x_proxy_protocol_patch_v2.patch
index 52c1ce7ff..ba63834e8 100644
--- a/net/nginx/patches/400-nginx-1.4.x_proxy_protocol_patch_v2.patch
+++ b/net/nginx/patches/400-nginx-1.4.x_proxy_protocol_patch_v2.patch
@@ -882,17 +882,6 @@ Index: nginx-1.4.7/src/http/ngx_http_request.c
#if (NGX_HTTP_SSL)
-@@ -1291,6 +1368,10 @@ ngx_http_read_request_header(ngx_http_re
- c = r->connection;
- rev = c->read;
-
-+fprintf(stderr, "DEBUG: pos: %p, last: %p, start: %p, end: %p\n",
-+ r->header_in->pos, r->header_in->last, r->header_in->start,
-+ r->header_in->end);
-+
- n = r->header_in->last - r->header_in->pos;
-
- if (n > 0) {
Index: nginx-1.4.7/src/http/ngx_http_upstream.c
===================================================================
--- nginx-1.4.7.orig/src/http/ngx_http_upstream.c