aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/python/Makefile3
-rw-r--r--lang/python3/Makefile8
-rw-r--r--lang/python3/files/python3-package.mk15
3 files changed, 17 insertions, 9 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 0c1be6de8..4ced2d9ce 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -115,8 +115,7 @@ define Build/InstallDev
$(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* \
$(1)/usr/lib/
$(CP) \
- $(STAGING_DIR_HOST)/lib/pkgconfig/python.pc \
- $(STAGING_DIR_HOST)/lib/pkgconfig/python2.pc \
+ $(STAGING_DIR_HOST)/lib/pkgconfig/python3.pc \
$(STAGING_DIR_HOST)/lib/pkgconfig/python-$(PYTHON_VERSION).pc \
$(1)/usr/lib/pkgconfig
$(CP) \
diff --git a/lang/python3/Makefile b/lang/python3/Makefile
index 2e9a8715c..d13a9f4da 100644
--- a/lang/python3/Makefile
+++ b/lang/python3/Makefile
@@ -31,7 +31,7 @@ HOST_BUILD_PARALLEL:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/Python-$(PKG_VERSION)
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/Python-$(PKG_VERSION)
-PKG_BUILD_DEPENDS:=libffi/host python3/host
+PKG_BUILD_DEPENDS:=python3/host
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
@@ -57,7 +57,7 @@ endef
define Package/python3-base
$(call Package/python3/Default)
TITLE:=Python $(PYTHON_VERSION) interpreter
- DEPENDS:=+libpthread +zlib +libffi
+ DEPENDS:=+libpthread +zlib +libffi +libopenssl
endef
define Package/python3-base/description
@@ -67,7 +67,7 @@ endef
define Package/python3
$(call Package/python3/Default)
- DEPENDS:=+python3-base +libncursesw +libbz2 +libgdbm +libsqlite3 +libdb47 +libopenssl
+ DEPENDS:=+python3-base +libncursesw +libbz2 +libgdbm +libsqlite3 +libdb47
endef
define Package/python3/description
@@ -170,9 +170,9 @@ endef
HOST_CONFIGURE_ARGS+= \
--without-cxx-main \
--without-pymalloc \
- --without-ensurepip \
--with-threads \
--prefix=$(STAGING_DIR_HOST) \
+ --with-ensurepip=upgrade \
CONFIG_SITE= \
OPT="$(HOST_CFLAGS)"
diff --git a/lang/python3/files/python3-package.mk b/lang/python3/files/python3-package.mk
index 9ab2da9e9..b28ec5833 100644
--- a/lang/python3/files/python3-package.mk
+++ b/lang/python3/files/python3-package.mk
@@ -20,8 +20,7 @@ PYTHON3:=python$(PYTHON3_VERSION)
HOST_PYTHON3_LIB_DIR:=$(STAGING_DIR_HOST)/lib/python$(PYTHON3_VERSION)
HOST_PYTHON3_BIN:=$(STAGING_DIR_HOST)/bin/python3
-PYTHON3PATH:=$(PYTHON3_LIB_DIR):$(STAGING_DIR)/$(PYTHON3_PKG_DIR)
-PYTHON3PATH+=:$(PKG_INSTALL_DIR)/$(PYTHON3_PKG_DIR)
+PYTHON3PATH:=$(PYTHON3_LIB_DIR):$(STAGING_DIR)/$(PYTHON3_PKG_DIR):$(PKG_INSTALL_DIR)/$(PYTHON3_PKG_DIR)
define HostPython3
( export PYTHONPATH="$(PYTHON3PATH)"; \
export PYTHONOPTIMIZE=""; \
@@ -39,6 +38,14 @@ ifdef CONFIG_USE_MIPS16
endif
define Py3Package
+
+ # Add default PyPackage filespec none defined
+ ifndef Py3Package/$(1)/filespec
+ define Py3Package/$(1)/filespec
+ +|$(PYTHON3_PKG_DIR)
+ endef
+ endif
+
$(call shexport,Py3Package/$(1)/filespec)
define Package/$(1)/install
@@ -46,6 +53,7 @@ define Py3Package
@echo "$$$$$$$$$$(call shvar,Py3Package/$(1)/filespec)" | ( \
IFS='|'; \
while read fop fspec fperm; do \
+ fop=`echo "$$$$$$$$fop" | tr -d ' \t\n'`; \
if [ "$$$$$$$$fop" = "+" ]; then \
if [ ! -e "$(PKG_INSTALL_DIR)$$$$$$$$fspec" ]; then \
echo "File not found '$(PKG_INSTALL_DIR)$$$$$$$$fspec'"; \
@@ -90,7 +98,7 @@ define Build/Compile/Py3Mod
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="$(TARGET_CPPFLAGS) -I$(PYTHON3_INC_DIR)" \
LDFLAGS="$(TARGET_LDFLAGS) -lpython$(PYTHON3_VERSION)" \
- _PYTHON_HOST_PLATFORM="linux-$(ARCH)" \
+ _PYTHON_HOST_PLATFORM=linux2 \
__PYVENV_LAUNCHER__="/usr/bin/$(PYTHON3)" \
$(3) \
, \
@@ -98,3 +106,4 @@ define Build/Compile/Py3Mod
)
find $(PKG_INSTALL_DIR) -name "*\.pyc" -o -name "*\.pyo" | xargs rm -f
endef
+