aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/isc-dhcp/Makefile2
-rw-r--r--net/isc-dhcp/files/dhclient.init24
-rw-r--r--net/isc-dhcp/files/dhclient6.init26
3 files changed, 26 insertions, 26 deletions
diff --git a/net/isc-dhcp/Makefile b/net/isc-dhcp/Makefile
index d35609e38..906cae673 100644
--- a/net/isc-dhcp/Makefile
+++ b/net/isc-dhcp/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=isc-dhcp
UPSTREAM_NAME:=dhcp
PKG_VERSION:=4.4.3-P1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
diff --git a/net/isc-dhcp/files/dhclient.init b/net/isc-dhcp/files/dhclient.init
index b5ffb411d..543cdf8cd 100644
--- a/net/isc-dhcp/files/dhclient.init
+++ b/net/isc-dhcp/files/dhclient.init
@@ -8,23 +8,23 @@ pid_file=/var/run/dhclient.pid
script_file=/usr/sbin/dhclient-script
start() {
- /usr/sbin/dhclient -q -nw -cf $config_file -lf $lease_file -pf $pid_file -sf $script_file `/sbin/uci get network.wan.ifname`
-
- if [ $? -ne 0 ]; then
- return 1
- fi
+ local ifname
+
+ . /lib/functions/network.sh
+
+ network_get_device ifname "wan" || return 1
+
+ /usr/sbin/dhclient -q -nw -cf $config_file -lf $lease_file -pf $pid_file -sf $script_file $ifname
+
+ [ $? -eq 0 ] || return 1
}
stop() {
- if [ ! -e $pid_file ]; then
- return 1
- fi
+ [ -e $pid_file ] || return 1
- kill -9 `cat $pid_file`
+ kill -9 $(cat $pid_file)
- if [ $? -ne 0 ]; then
- return 1
- fi
+ [ $? -eq 0 ] || return 1
rm $pid_file
}
diff --git a/net/isc-dhcp/files/dhclient6.init b/net/isc-dhcp/files/dhclient6.init
index 630c3f25f..dd1a095b1 100644
--- a/net/isc-dhcp/files/dhclient6.init
+++ b/net/isc-dhcp/files/dhclient6.init
@@ -8,23 +8,23 @@ pid_file=/var/run/dhclient6.pid
script_file=/usr/sbin/dhclient-script
start() {
- /usr/sbin/dhclient -q -nw -6 -cf $config_file -lf $lease_file -pf $pid_file -sf $script_file `/sbin/uci get network.wan.ifname`
-
- if [ $? -ne 0 ]; then
- return 1
- fi
+ local ifname
+
+ . /lib/functions/network.sh
+
+ network_get_device ifname "wan" || return 1
+
+ /usr/sbin/dhclient -q -nw -6 -cf $config_file -lf $lease_file -pf $pid_file -sf $script_file $ifname
+
+ [ $? -eq 0 ] || return 1
}
stop() {
- if [ ! -e $pid_file ]; then
- return 1
- fi
+ [ -e $pid_file ] || return 1
+
+ kill -9 $(cat $pid_file)
- kill -9 `cat $pid_file`
+ [ $? -eq 0 ] || return 1
- if [ $? -ne 0 ]; then
- return 1
- fi
-
rm $pid_file
}