aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--libs/elektra/Makefile2
-rw-r--r--libs/elektra/patches/010-gcc13.patch19
2 files changed, 20 insertions, 1 deletions
diff --git a/libs/elektra/Makefile b/libs/elektra/Makefile
index d2a0e9601..975882226 100644
--- a/libs/elektra/Makefile
+++ b/libs/elektra/Makefile
@@ -15,7 +15,7 @@ PKG_NAME:=elektra
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE.md
PKG_VERSION:=0.9.7
-PKG_RELEASE:=4
+PKG_RELEASE:=5
# Use this for official releasees
PKG_HASH:=12b7b046004db29317b7b937dc794abf719c400ba3115af8d41849127b562681
diff --git a/libs/elektra/patches/010-gcc13.patch b/libs/elektra/patches/010-gcc13.patch
new file mode 100644
index 000000000..35195de2f
--- /dev/null
+++ b/libs/elektra/patches/010-gcc13.patch
@@ -0,0 +1,19 @@
+From 19fe46ecb796c0d30d66dd7e7038fd7f2d6f9bf4 Mon Sep 17 00:00:00 2001
+From: Florian Lindner <florian.lindner@student.tuwien.ac.at>
+Date: Thu, 8 Jun 2023 16:55:34 +0200
+Subject: [PATCH] bindings: include <cstdint> in key.hpp for uint8_t
+
+---
+ src/bindings/cpp/include/key.hpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/src/bindings/cpp/include/key.hpp
++++ b/src/bindings/cpp/include/key.hpp
+@@ -10,6 +10,7 @@
+ #define ELEKTRA_KEY_HPP
+
+ #include <cstdarg>
++#include <cstdint>
+ #include <cstring>
+ #include <functional>
+ #include <locale>