aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
3 files changed, 19 insertions, 1 deletions
diff --git a/utils/collectd/Makefile b/utils/collectd/Makefile
index 830804886..02b1b5397 100644
--- a/utils/collectd/Makefile
+++ b/utils/collectd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=collectd
PKG_VERSION:=5.9.0
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://collectd.org/files/ \
diff --git a/utils/collectd/files/collectd.init b/utils/collectd/files/collectd.init
index 89715d4c4..89af365c2 100644
--- a/utils/collectd/files/collectd.init
+++ b/utils/collectd/files/collectd.init
@@ -333,6 +333,11 @@ process_config() {
config_foreach process_plugins plugin
}
+service_triggers()
+{
+ procd_add_reload_trigger "collectd"
+}
+
start_service() {
process_config
@@ -345,3 +350,7 @@ start_service() {
procd_set_param respawn
procd_close_instance
}
+
+reload_service() {
+ restart "$@"
+}
diff --git a/utils/collectd/files/usr/share/collectd/plugin/logfile.json b/utils/collectd/files/usr/share/collectd/plugin/logfile.json
new file mode 100644
index 000000000..fd1608497
--- /dev/null
+++ b/utils/collectd/files/usr/share/collectd/plugin/logfile.json
@@ -0,0 +1,9 @@
+{
+ "string": [
+ "LogLevel",
+ "File"
+ ],
+ "bool": [
+ "Timestamp"
+ ]
+}