aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/openthread-br/Makefile7
-rw-r--r--net/openthread-br/patches/100-rest-support-deleting-the-dataset.patch9
2 files changed, 4 insertions, 12 deletions
diff --git a/net/openthread-br/Makefile b/net/openthread-br/Makefile
index 1b42cceee..d5b61b1e1 100644
--- a/net/openthread-br/Makefile
+++ b/net/openthread-br/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openthread-br
PKG_SOURCE_DATE:=2023-08-01
PKG_SOURCE_VERSION:=1738d8cd8b42106c2ef1262fbbac2f06beab83ba
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=https://github.com/openthread/ot-br-posix.git
@@ -74,7 +74,9 @@ CMAKE_OPTIONS += \
-DOTBR_SRP_SERVER_AUTO_ENABLE:BOOL=ON \
-DOTBR_TREL:BOOL=ON
-TARGET_CFLAGS += -DOPENTHREAD_POSIX_CONFIG_DAEMON_SOCKET_BASENAME=\\\"/var/run/openthread-%s\\\"
+TARGET_CFLAGS += -DOPENTHREAD_POSIX_CONFIG_DAEMON_SOCKET_BASENAME=\\\"/var/run/openthread-%s\\\" \
+ -I$(STAGING_DIR)/usr/include/mdns \
+ -L$(STAGING_DIR)/usr/lib/mdns
define Package/luci-app-openthread/install
$(INSTALL_DIR) \
@@ -94,7 +96,6 @@ endef
define Package/openthread-br/install
$(INSTALL_DIR) \
- $(1)/etc/init.d \
$(1)/lib/netifd/proto \
$(1)/usr/sbin \
$(1)/var/lib/thread
diff --git a/net/openthread-br/patches/100-rest-support-deleting-the-dataset.patch b/net/openthread-br/patches/100-rest-support-deleting-the-dataset.patch
index 014c306f3..5605acb15 100644
--- a/net/openthread-br/patches/100-rest-support-deleting-the-dataset.patch
+++ b/net/openthread-br/patches/100-rest-support-deleting-the-dataset.patch
@@ -16,8 +16,6 @@ otDatasetCreateNewNetwork).
src/rest/resource.hpp | 1 +
3 files changed, 57 insertions(+)
-diff --git a/src/rest/openapi.yaml b/src/rest/openapi.yaml
-index 2ba2a4dd56..2edc4af29a 100644
--- a/src/rest/openapi.yaml
+++ b/src/rest/openapi.yaml
@@ -248,6 +248,18 @@ paths:
@@ -55,8 +53,6 @@ index 2ba2a4dd56..2edc4af29a 100644
components:
schemas:
LeaderData:
-diff --git a/src/rest/resource.cpp b/src/rest/resource.cpp
-index a60e9d9483..829835341a 100644
--- a/src/rest/resource.cpp
+++ b/src/rest/resource.cpp
@@ -767,12 +767,47 @@ exit:
@@ -107,8 +103,6 @@ index a60e9d9483..829835341a 100644
case HttpMethod::kGet:
GetDataset(aDatasetType, aRequest, aResponse);
break;
-diff --git a/src/rest/resource.hpp b/src/rest/resource.hpp
-index d79085dbfc..362e501471 100644
--- a/src/rest/resource.hpp
+++ b/src/rest/resource.hpp
@@ -150,6 +150,7 @@ private:
@@ -119,6 +113,3 @@ index d79085dbfc..362e501471 100644
void DeleteOutDatedDiagnostic(void);
void UpdateDiag(std::string aKey, std::vector<otNetworkDiagTlv> &aDiag);
---
-2.41.0
-