aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--libs/gnutls/Makefile2
-rw-r--r--libs/gnutls/patches/001-camellia256-gcm-corrected-regression.patch26
2 files changed, 27 insertions, 1 deletions
diff --git a/libs/gnutls/Makefile b/libs/gnutls/Makefile
index 40b807802..61e188ae9 100644
--- a/libs/gnutls/Makefile
+++ b/libs/gnutls/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gnutls
PKG_VERSION:=3.4.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
diff --git a/libs/gnutls/patches/001-camellia256-gcm-corrected-regression.patch b/libs/gnutls/patches/001-camellia256-gcm-corrected-regression.patch
new file mode 100644
index 000000000..e29e38eb3
--- /dev/null
+++ b/libs/gnutls/patches/001-camellia256-gcm-corrected-regression.patch
@@ -0,0 +1,26 @@
+From 6adde30fcea02d3cb541b5a5bfb3b12074f1f3e9 Mon Sep 17 00:00:00 2001
+From: Nikos Mavrogiannopoulos <nmav@redhat.com>
+Date: Thu, 14 May 2015 14:00:11 +0200
+Subject: [PATCH] camellia256-gcm: corrected regression
+
+Reported by Manuel Pegourie-Gonnard.
+---
+ lib/nettle/cipher.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/nettle/cipher.c b/lib/nettle/cipher.c
+index 59e70dd..74e4203 100644
+--- a/lib/nettle/cipher.c
++++ b/lib/nettle/cipher.c
+@@ -302,7 +302,7 @@ static const struct nettle_cipher_st builtin_ciphers[] = {
+ .ctx_size = sizeof(struct gcm_camellia256_ctx),
+ .encrypt = _gcm_encrypt,
+ .decrypt = _gcm_decrypt,
+- .set_encrypt_key = (nettle_set_key_func*)gcm_camellia128_set_key,
++ .set_encrypt_key = (nettle_set_key_func*)gcm_camellia256_set_key,
+ .set_decrypt_key = (nettle_set_key_func*)gcm_camellia256_set_key,
+
+ .tag = (nettle_hash_digest_func*)gcm_camellia256_digest,
+--
+2.1.4
+