aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/haproxy/Makefile4
-rwxr-xr-xnet/haproxy/get-latest-patches.sh2
-rw-r--r--net/haproxy/patches/000-BUG-MINOR-stats-Add-a-missing-break-in-a-switch-statement.patch27
-rw-r--r--net/haproxy/patches/000-OPENWRT-add-uclibc-support.patch (renamed from net/haproxy/patches/001-OPENWRT-add-uclibc-support.patch)0
-rw-r--r--net/haproxy/patches/001-OPENWRT-openssl-deprecated.patch (renamed from net/haproxy/patches/002-OPENWRT-openssl-deprecated.patch)0
5 files changed, 3 insertions, 30 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index f841ec263..29adcbcdd 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -10,12 +10,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=haproxy
-PKG_VERSION:=2.0.7
+PKG_VERSION:=2.0.8
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.haproxy.org/download/2.0/src
-PKG_HASH:=3873cd72028ed1bd2506dd174e01a92620e92683092f34234c96e067dcb113dc
+PKG_HASH:=c37e1e8515ad6f9781a0ac336ca88787f3bb52252fb2bdad9919ba16323c280a
PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>, \
Christian Lachner <gladiac@gmail.com>
diff --git a/net/haproxy/get-latest-patches.sh b/net/haproxy/get-latest-patches.sh
index 8ef123d21..f15aef24c 100755
--- a/net/haproxy/get-latest-patches.sh
+++ b/net/haproxy/get-latest-patches.sh
@@ -1,7 +1,7 @@
#!/bin/sh
CLONEURL=https://git.haproxy.org/git/haproxy-2.0.git
-BASE_TAG=v2.0.7
+BASE_TAG=v2.0.8
TMP_REPODIR=tmprepo
PATCHESDIR=patches
diff --git a/net/haproxy/patches/000-BUG-MINOR-stats-Add-a-missing-break-in-a-switch-statement.patch b/net/haproxy/patches/000-BUG-MINOR-stats-Add-a-missing-break-in-a-switch-statement.patch
deleted file mode 100644
index 07874ddd6..000000000
--- a/net/haproxy/patches/000-BUG-MINOR-stats-Add-a-missing-break-in-a-switch-statement.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-commit c0104fc33ccf7e843efd37cc033e4c3849a37844
-Author: Christopher Faulet <cfaulet@haproxy.com>
-Date: Sat Sep 28 10:37:31 2019 +0200
-
- BUG/MINOR: stats: Add a missing break in a switch statement
-
- A break is missing in the switch statement in the function
- stats_emit_json_data_field(). This bug was introduced in the commit 88a0db28a
- ("MINOR: stats: Add the support of float fields in stats").
-
- This patch fixes the issue #302 and #303. It must be backported to 2.0.
-
- (cherry picked from commit 52c91bb72ccf20e75f2f79da6ebe345cb2a768f4)
- Signed-off-by: Christopher Faulet <cfaulet@haproxy.com>
-
-diff --git a/src/stats.c b/src/stats.c
-index 5819f459..9ec5066f 100644
---- a/src/stats.c
-+++ b/src/stats.c
-@@ -399,6 +399,7 @@ int stats_emit_json_data_field(struct buffer *out, const struct field *f)
- type = "\"u64\"";
- snprintf(buf, sizeof(buf), "%llu",
- (unsigned long long) f->u.u64);
-+ break;
- case FF_FLT: type = "\"flt\"";
- snprintf(buf, sizeof(buf), "%f", f->u.flt);
- break;
diff --git a/net/haproxy/patches/001-OPENWRT-add-uclibc-support.patch b/net/haproxy/patches/000-OPENWRT-add-uclibc-support.patch
index 275702522..275702522 100644
--- a/net/haproxy/patches/001-OPENWRT-add-uclibc-support.patch
+++ b/net/haproxy/patches/000-OPENWRT-add-uclibc-support.patch
diff --git a/net/haproxy/patches/002-OPENWRT-openssl-deprecated.patch b/net/haproxy/patches/001-OPENWRT-openssl-deprecated.patch
index 541077e23..541077e23 100644
--- a/net/haproxy/patches/002-OPENWRT-openssl-deprecated.patch
+++ b/net/haproxy/patches/001-OPENWRT-openssl-deprecated.patch