aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/perl-device-serialport/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/lang/perl-device-serialport/Makefile b/lang/perl-device-serialport/Makefile
index 505d356cd..346732ca2 100644
--- a/lang/perl-device-serialport/Makefile
+++ b/lang/perl-device-serialport/Makefile
@@ -41,7 +41,20 @@ define Build/Configure
$(call perlmod/Configure,,)
endef
+MOD_CFLAGS_PERL += $(if $(CONFIG_HOST_OS_MACOS),-I$(PKG_BUILD_DIR)/macos_compat,)
+
define Build/Compile
+
+ifeq ($(CONFIG_HOST_OS_MACOS),y)
+ #Zeroize macos specific system headers found by ./configure
+ mkdir -p $(PKG_BUILD_DIR)/macos_compat
+ mkdir -p $(PKG_BUILD_DIR)/macos_compat/sys
+ mkdir -p $(PKG_BUILD_DIR)/macos_compat/IOKit
+ mkdir -p $(PKG_BUILD_DIR)/macos_compat/IOKit/serial
+ echo '' > $(PKG_BUILD_DIR)/macos_compat/sys/ttycom.h
+ echo '' > $(PKG_BUILD_DIR)/macos_compat/IOKit/serial/ioss.h
+endif
+
$(call perlmod/Compile,,)
endef