aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/samba4/Makefile2
-rw-r--r--net/samba4/patches/103-samba-4.12-unbundle-libunwind.patch23
-rw-r--r--net/samba4/patches/104-samba-4.12-unbundle-icu.patch30
3 files changed, 54 insertions, 1 deletions
diff --git a/net/samba4/Makefile b/net/samba4/Makefile
index f65baf507..661641bc5 100644
--- a/net/samba4/Makefile
+++ b/net/samba4/Makefile
@@ -3,7 +3,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=samba
PKG_VERSION:=4.12.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:= \
diff --git a/net/samba4/patches/103-samba-4.12-unbundle-libunwind.patch b/net/samba4/patches/103-samba-4.12-unbundle-libunwind.patch
new file mode 100644
index 000000000..043b0a3b0
--- /dev/null
+++ b/net/samba4/patches/103-samba-4.12-unbundle-libunwind.patch
@@ -0,0 +1,23 @@
+--- a/lib/util/wscript_configure 2020-06-14
++++ b/lib/util/wscript_configure 2020-06-14
+@@ -11,13 +11,13 @@ conf.CHECK_FUNCS_IN('backtrace backtrace
+ conf.CHECK_HEADERS('execinfo.h')
+
+ conf.SET_TARGET_TYPE('LIBUNWIND', 'EMPTY')
+-if conf.check_cfg(package='libunwind-generic',
+- args='--cflags --libs',
+- msg='Checking for libunwind',
+- uselib_store='LIBUNWIND',
+- mandatory=False):
+- if conf.CHECK_HEADERS('libunwind.h'):
+- conf.SET_TARGET_TYPE('LIBUNWIND', 'SYSLIB')
++# if conf.check_cfg(package='libunwind-generic',
++ # args='--cflags --libs',
++ # msg='Checking for libunwind',
++ # uselib_store='LIBUNWIND',
++ # mandatory=False):
++ # if conf.CHECK_HEADERS('libunwind.h'):
++ # conf.SET_TARGET_TYPE('LIBUNWIND', 'SYSLIB')
+
+ conf.CHECK_STRUCTURE_MEMBER('struct statvfs', 'f_frsize', define='HAVE_FRSIZE', headers='sys/statvfs.h')
+
diff --git a/net/samba4/patches/104-samba-4.12-unbundle-icu.patch b/net/samba4/patches/104-samba-4.12-unbundle-icu.patch
new file mode 100644
index 000000000..fcba20609
--- /dev/null
+++ b/net/samba4/patches/104-samba-4.12-unbundle-icu.patch
@@ -0,0 +1,30 @@
+--- a/lib/util/charset/wscript_configure 2020-06-14
++++ b/lib/util/charset/wscript_configure 2020-06-14
+@@ -37,15 +37,15 @@ conf.CHECK_CODE('''
+ lib='iconv',
+ headers='errno.h iconv.h')
+
+-if conf.CHECK_CFG(package='icu-i18n',
+- args='--cflags --libs',
+- msg='Checking for icu-i18n',
+- uselib_store='ICU_I18N'):
+- for lib in conf.env['LIB_ICU_I18N']:
+- conf.CHECK_LIB(lib, shlib=True, mandatory=True)
+- conf.env['icu-libs'] = ' '.join(conf.env['LIB_ICU_I18N'])
+- if not conf.CHECK_HEADERS('unicode/ustring.h'):
+- conf.fatal('Found libicu, but unicode/ustring.h is missing')
+- conf.DEFINE('HAVE_UTF8_NORMALISATION', 1)
+-else:
+- conf.env['icu-libs'] = ''
++# if conf.CHECK_CFG(package='icu-i18n',
++ # args='--cflags --libs',
++ # msg='Checking for icu-i18n',
++ # uselib_store='ICU_I18N'):
++ # for lib in conf.env['LIB_ICU_I18N']:
++ # conf.CHECK_LIB(lib, shlib=True, mandatory=True)
++ # conf.env['icu-libs'] = ' '.join(conf.env['LIB_ICU_I18N'])
++ # if not conf.CHECK_HEADERS('unicode/ustring.h'):
++ # conf.fatal('Found libicu, but unicode/ustring.h is missing')
++ # conf.DEFINE('HAVE_UTF8_NORMALISATION', 1)
++# else:
++conf.env['icu-libs'] = ''