aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/adblock/Makefile2
-rw-r--r--net/adblock/files/adblock-helper.sh8
-rwxr-xr-xnet/adblock/files/adblock-update.sh2
3 files changed, 8 insertions, 4 deletions
diff --git a/net/adblock/Makefile b/net/adblock/Makefile
index de591c49b..9f5d2611e 100644
--- a/net/adblock/Makefile
+++ b/net/adblock/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=adblock
-PKG_VERSION:=1.5.2
+PKG_VERSION:=1.5.3
PKG_RELEASE:=1
PKG_LICENSE:=GPL-3.0+
PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
diff --git a/net/adblock/files/adblock-helper.sh b/net/adblock/files/adblock-helper.sh
index 2253075e5..b177fb636 100644
--- a/net/adblock/files/adblock-helper.sh
+++ b/net/adblock/files/adblock-helper.sh
@@ -6,7 +6,7 @@
#
LC_ALL=C
PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-adb_scriptver="1.5.2"
+adb_scriptver="1.5.3"
adb_mincfgver="2.5"
adb_hotplugif=""
adb_lanif="lan"
@@ -242,10 +242,12 @@ f_envcheck()
f_depend "wget -" "true"
if [ "${package_ok}" = "true" ]
then
- adb_fetch="$(which wget)"
+ adb_fetch="$(which /usr/bin/wget* | head -1)"
fetch_parm="--no-config --quiet --tries=1 --no-cache --no-cookies --max-redirect=0 --dns-timeout=${adb_fetchttl} --connect-timeout=${adb_fetchttl} --read-timeout=${adb_fetchttl}"
response_parm="--spider --server-response"
- else
+ fi
+ if [ -z "${adb_fetch}" ]
+ then
rc=-1
f_log "please install 'uclient-fetch' or 'wget' with ssl support to use adblock"
f_exit
diff --git a/net/adblock/files/adblock-update.sh b/net/adblock/files/adblock-update.sh
index c7df4ddb1..500455cf2 100755
--- a/net/adblock/files/adblock-update.sh
+++ b/net/adblock/files/adblock-update.sh
@@ -41,6 +41,8 @@ f_envcheck
# main loop for all block list sources
#
+f_log "use '${adb_fetch}' for list downloads"
+
for src_name in ${adb_sources}
do
# check disabled sources