aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/unbound/Makefile4
-rwxr-xr-xnet/unbound/files/unbound.init9
2 files changed, 6 insertions, 7 deletions
diff --git a/net/unbound/Makefile b/net/unbound/Makefile
index 43dea0a20..93856b2bd 100644
--- a/net/unbound/Makefile
+++ b/net/unbound/Makefile
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=unbound
PKG_VERSION:=1.7.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
-PKG_MAINTAINER:=Eric Luehrsen <ericluehrsen@hotmail.com>
+PKG_MAINTAINER:=Eric Luehrsen <ericluehrsen@gmail.com>
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.unbound.net/downloads
diff --git a/net/unbound/files/unbound.init b/net/unbound/files/unbound.init
index ac0dd5806..2f93b4d65 100755
--- a/net/unbound/files/unbound.init
+++ b/net/unbound/files/unbound.init
@@ -16,10 +16,6 @@ PROG=/usr/sbin/unbound
##############################################################################
-. /usr/lib/unbound/unbound.sh
-
-##############################################################################
-
boot() {
UNBOUND_BOOT=1
start "$@"
@@ -34,10 +30,11 @@ start_service() {
fi
# complex UCI work
+ . /usr/lib/unbound/unbound.sh
unbound_start
# standard procd clause
- procd_open_instance
+ procd_open_instance "unbound"
procd_set_param command $PROG -d -c $UNBOUND_CONFFILE
procd_set_param respawn
procd_close_instance
@@ -46,6 +43,8 @@ start_service() {
##############################################################################
stop_service() {
+ # clean up
+ . /usr/lib/unbound/unbound.sh
unbound_stop
# Wait! on restart Unbound may take time writing closure stats to syslog