aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/nginx/Config.in5
-rw-r--r--net/nginx/Makefile12
2 files changed, 10 insertions, 7 deletions
diff --git a/net/nginx/Config.in b/net/nginx/Config.in
index 1b6062615..2597f7fb6 100644
--- a/net/nginx/Config.in
+++ b/net/nginx/Config.in
@@ -162,13 +162,15 @@ config NGINX_NAXSI
bool
prompt "Enable NAXSI module"
select PACKAGE_nginx-naxsi
+ default y
help
Enable support for NAXSI WAF.
config NGINX_PROXYPROTOCOL
bool
- prompt "Enable NAXSI proxyprotocol"
+ prompt "Enable HAProxy proxyprotocol"
select PACKAGE_nginx-proxyprotocol
+ default y
help
Enable support for NAXSI WAF.
@@ -176,6 +178,7 @@ config NGINX_SYSLOG
bool
prompt "Enable Syslog module"
select PACKAGE_nginx-syslog
+ default y
help
Provides the ability log to a remote destination
diff --git a/net/nginx/Makefile b/net/nginx/Makefile
index 06d92758b..89a7ce99e 100644
--- a/net/nginx/Makefile
+++ b/net/nginx/Makefile
@@ -252,8 +252,8 @@ endef
define Package/nginx-naxsi
MENU:=1
$(call Package/nginx)
- TITLE+= nginx-naxsi
- DEPENDS:=nginx
+ TITLE:=nginx-naxsi
+ DEPENDS:=nginx @NGINX_NAXSI
endef
define Package/nginx-naxsi/description
@@ -263,8 +263,8 @@ endef
define Package/nginx-proxyprotocol
MENU:=1
$(call Package/nginx)
- TITLE+= nginx-proxyprotocol
- DEPENDS:=nginx
+ TITLE:=nginx
+ DEPENDS:=nginx @NGINX_PROXYPROTOCOL
endef
define Package/nginx-proxyprotocol/description
@@ -274,8 +274,8 @@ endef
define Package/nginx-syslog
MENU:=1
$(call Package/nginx)
- TITLE+= nginx-syslog
- DEPENDS:=nginx
+ TITLE:=nginx-syslog
+ DEPENDS:=nginx @NGINX_SYSLOG
endef
define Package/nginx-syslog/description