aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/socat/Makefile4
-rw-r--r--net/socat/patches/100-musl-compat.patch23
2 files changed, 2 insertions, 25 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index 4fac5f8ae..725a8464d 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -7,18 +7,18 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=socat
PKG_VERSION:=1.7.3.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download
PKG_HASH:=0dd63ffe498168a4aac41d307594c5076ff307aa0ac04b141f8f1cec6594d04a
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
-
PKG_LICENSE:=GPL-2.0 OpenSSL
PKG_LICENSE_FILES:=COPYING COPYING.OpenSSL
PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/net/socat/patches/100-musl-compat.patch b/net/socat/patches/100-musl-compat.patch
deleted file mode 100644
index ae5c8d0d7..000000000
--- a/net/socat/patches/100-musl-compat.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/sysincludes.h
-+++ b/sysincludes.h
-@@ -79,6 +79,9 @@
- #endif
- #if HAVE_NETDB_H && (_WITH_IP4 || _WITH_IP6)
- #include <netdb.h> /* struct hostent, gethostbyname() */
-+#if !(__UCLIBC__ || __GLIBC__)
-+#define NETDB_INTERNAL -1
-+#endif
- #endif
- #if HAVE_SYS_UN_H && WITH_UNIX
- #include <sys/un.h> /* struct sockaddr_un, unix domain sockets */
-@@ -139,8 +142,10 @@
- #include <netpacket/packet.h>
- #endif
- #if HAVE_NETINET_IF_ETHER_H
-+#if defined(__UCLIBC__) || defined(__GLIBC__)
- #include <netinet/if_ether.h>
- #endif
-+#endif
- #if HAVE_LINUX_IF_TUN_H
- #include <linux/if_tun.h>
- #endif