aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
3 files changed, 6 insertions, 3 deletions
diff --git a/net/dhtd/Makefile b/net/dhtd/Makefile
index bb09f8b4a..8cc8b22d5 100644
--- a/net/dhtd/Makefile
+++ b/net/dhtd/Makefile
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dhtd
-PKG_VERSION:=0.2.1
+PKG_VERSION:=0.2.4
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/mwarning/dhtd/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=65d2e0d6a3648fe3619d9fa4bef34a76c22577b7fe3fe460f96ac10510c3f06a
+PKG_HASH:=0f35cd0016689682b277f9769ec1e95c3c1321479cedc9727abc0bc91a0427d5
PKG_MAINTAINER:=Moritz Warning <moritzwarning@web.de>
PKG_LICENSE:=MIT
diff --git a/net/dhtd/files/dhtd.config b/net/dhtd/files/dhtd.config
index 60b15b8a6..e933e65b5 100644
--- a/net/dhtd/files/dhtd.config
+++ b/net/dhtd/files/dhtd.config
@@ -15,6 +15,9 @@ config dhtd
list peer 'bttracker.debian.org:6881'
list peer 'router.bittorrent.com:6881'
+## Execute a script for each result
+# option execute '/root/on_result.sh'
+
## Bind the DHT to this port.
# option port '6881'
diff --git a/net/dhtd/files/dhtd.init b/net/dhtd/files/dhtd.init
index 3cd797057..a3b155298 100755
--- a/net/dhtd/files/dhtd.init
+++ b/net/dhtd/files/dhtd.init
@@ -54,7 +54,7 @@ start_instance() {
OPTS=""
- append_opts "$cfg" verbosity peerfile port
+ append_opts "$cfg" verbosity peerfile port execute
config_get ifname "$cfg" "ifname"
if network_get_device IFNAME "$ifname";then