aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/sstp-client/Makefile2
-rwxr-xr-xnet/sstp-client/files/lib/netifd/proto/sstp.sh7
2 files changed, 5 insertions, 4 deletions
diff --git a/net/sstp-client/Makefile b/net/sstp-client/Makefile
index 8d7ff0738..0c72655f0 100644
--- a/net/sstp-client/Makefile
+++ b/net/sstp-client/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=sstp-client
PKG_VERSION:=1.0.19
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://gitlab.com/sstp-project/sstp-client/-/archive/1.0.19/
diff --git a/net/sstp-client/files/lib/netifd/proto/sstp.sh b/net/sstp-client/files/lib/netifd/proto/sstp.sh
index f8cb704c5..f5c9e6ec3 100755
--- a/net/sstp-client/files/lib/netifd/proto/sstp.sh
+++ b/net/sstp-client/files/lib/netifd/proto/sstp.sh
@@ -10,6 +10,7 @@
proto_sstp_init_config() {
proto_config_add_string "server"
+ proto_config_add_string "port"
proto_config_add_string "username"
proto_config_add_string "password"
proto_config_add_string "pppd_options"
@@ -28,7 +29,7 @@ proto_sstp_setup() {
local iface="$2"
local ifname="sstp-$config"
- local ip serv_addr server ipv6 defaultroute peerdns
+ local ip serv_addr server port ipv6 defaultroute peerdns
json_get_var server server && {
for ip in $(resolveip -t 5 "$server"); do
( proto_add_host_dependency "$config" "$ip" )
@@ -42,7 +43,7 @@ proto_sstp_setup() {
exit 1
}
- json_get_vars username password pppd_options sstp_options log_level ipv6 defaultroute peerdns
+ json_get_vars port username password pppd_options sstp_options log_level ipv6 defaultroute peerdns
if [ "$ipv6" = 1 ]; then
ipv6=1
else
@@ -82,7 +83,7 @@ proto_sstp_setup() {
--save-server-route \
--ipparam $config \
$sstp_options \
- $server \
+ $server${port:+:$port} \
ifname $ifname \
require-mschap-v2 \
${ipv6:++ipv6} \