aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--utils/bluez/Makefile9
-rw-r--r--utils/bluez/files/audio.conf1
-rw-r--r--utils/bluez/patches/001-bcm43xx-Add-bcm43xx-3wire-variant.patch2
-rw-r--r--utils/bluez/patches/003-Increase-firmware-load-timeout-to-30s.patch2
-rw-r--r--utils/bluez/patches/200-uart-speed.patch40
-rw-r--r--utils/bluez/patches/201-readline.patch45
6 files changed, 36 insertions, 63 deletions
diff --git a/utils/bluez/Makefile b/utils/bluez/Makefile
index 1c1816343..245e45d5f 100644
--- a/utils/bluez/Makefile
+++ b/utils/bluez/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bluez
-PKG_VERSION:=5.38
+PKG_VERSION:=5.47
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/bluetooth/
-PKG_HASH:=0618c5440be6715805060ab5eea930526f34089c437bf61819447b160254f4df
+PKG_HASH:=cf75bf7cd5d564f21cc4a2bd01d5c39ce425397335fd47d9bbe43af0a58342c8
PKG_LICENSE:=GPL-2.0+
PKG_LICENSE_FILES:=COPYING
@@ -70,7 +70,7 @@ define Package/bluez-daemon/conffiles
/etc/bluetooth/main.conf
/etc/bluetooth/network.conf
/etc/bluetooth/input.conf
-/etc/bluetooth/proximity.conf
+/etc/bluetooth/audio.conf
/etc/config/bluetooth
endef
@@ -92,6 +92,7 @@ CONFIGURE_ARGS += \
--disable-systemd \
--disable-test \
--disable-udev \
+ --enable-deprecated
TARGET_CPPFLAGS += \
-D_GNU_SOURCE
@@ -148,7 +149,7 @@ define Package/bluez-daemon/install
$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/main.conf $(1)/etc/bluetooth/main.conf
$(INSTALL_DATA) $(PKG_BUILD_DIR)/profiles/network/network.conf $(1)/etc/bluetooth/network.conf
$(INSTALL_DATA) $(PKG_BUILD_DIR)/profiles/input/input.conf $(1)/etc/bluetooth/input.conf
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/profiles/proximity/proximity.conf $(1)/etc/bluetooth/proximity.conf
+ $(INSTALL_DATA) ./files/audio.conf $(1)/etc/bluetooth/audio.conf
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/bluetoothd.init $(1)/etc/init.d/bluetoothd
endef
diff --git a/utils/bluez/files/audio.conf b/utils/bluez/files/audio.conf
new file mode 100644
index 000000000..0455c6c01
--- /dev/null
+++ b/utils/bluez/files/audio.conf
@@ -0,0 +1 @@
+Enable=Source,Sink,Media,Socket
diff --git a/utils/bluez/patches/001-bcm43xx-Add-bcm43xx-3wire-variant.patch b/utils/bluez/patches/001-bcm43xx-Add-bcm43xx-3wire-variant.patch
index 96e8a26c5..15eb6e1da 100644
--- a/utils/bluez/patches/001-bcm43xx-Add-bcm43xx-3wire-variant.patch
+++ b/utils/bluez/patches/001-bcm43xx-Add-bcm43xx-3wire-variant.patch
@@ -9,7 +9,7 @@ Subject: [PATCH 1/4] bcm43xx: Add bcm43xx-3wire variant
--- a/tools/hciattach.c
+++ b/tools/hciattach.c
-@@ -1144,6 +1144,9 @@ struct uart_t uart[] = {
+@@ -1090,6 +1090,9 @@ struct uart_t uart[] = {
{ "bcm43xx", 0x0000, 0x0000, HCI_UART_H4, 115200, 3000000,
FLOW_CTL, DISABLE_PM, NULL, bcm43xx, NULL },
diff --git a/utils/bluez/patches/003-Increase-firmware-load-timeout-to-30s.patch b/utils/bluez/patches/003-Increase-firmware-load-timeout-to-30s.patch
index fa0948d92..74911d3ca 100644
--- a/utils/bluez/patches/003-Increase-firmware-load-timeout-to-30s.patch
+++ b/utils/bluez/patches/003-Increase-firmware-load-timeout-to-30s.patch
@@ -9,7 +9,7 @@ Subject: [PATCH 3/4] Increase firmware load timeout to 30s
--- a/tools/hciattach.c
+++ b/tools/hciattach.c
-@@ -1293,7 +1293,7 @@ int main(int argc, char *argv[])
+@@ -1239,7 +1239,7 @@ int main(int argc, char *argv[])
{
struct uart_t *u = NULL;
int detach, printpid, raw, opt, i, n, ld, err;
diff --git a/utils/bluez/patches/200-uart-speed.patch b/utils/bluez/patches/200-uart-speed.patch
deleted file mode 100644
index ebe0153e2..000000000
--- a/utils/bluez/patches/200-uart-speed.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- a/tools/hciattach.c
-+++ b/tools/hciattach.c
-@@ -101,20 +101,37 @@ int uart_speed(int s)
- return B230400;
- case 460800:
- return B460800;
-+/* FIX: Not all platform support this high serial speed
-+ claudyus84 @gamil.com
-+*/
-+#ifdef B500000
- case 500000:
- return B500000;
-+#endif
-+#ifdef B576000
- case 576000:
- return B576000;
-+#endif
-+#ifdef B921600
- case 921600:
- return B921600;
-+#endif
-+#ifdef B1000000
- case 1000000:
- return B1000000;
-+#endif
-+#ifdef B1152000
- case 1152000:
- return B1152000;
-+#endif
-+#ifdef B1500000
- case 1500000:
- return B1500000;
-+#endif
-+#ifdef B2000000
- case 2000000:
- return B2000000;
-+#endif
- #ifdef B2500000
- case 2500000:
- return B2500000;
diff --git a/utils/bluez/patches/201-readline.patch b/utils/bluez/patches/201-readline.patch
index 45e155325..579437162 100644
--- a/utils/bluez/patches/201-readline.patch
+++ b/utils/bluez/patches/201-readline.patch
@@ -1,22 +1,24 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -2441,7 +2441,7 @@ unit_tests = $(am__append_35) unit/test-
+--- a/Makefile.in 2017-09-14 11:47:06.000000000 +0200
++++ b/Makefile.in 2017-09-15 02:52:39.315926972 +0200
+@@ -2447,7 +2447,7 @@
@CLIENT_TRUE@ monitor/uuid.h monitor/uuid.c
- @CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la @GLIB_LIBS@ @DBUS_LIBS@ \
--@CLIENT_TRUE@ -lreadline
-+@CLIENT_TRUE@ -lreadline -lncurses
+ @CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
+-@CLIENT_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -lreadline
++@CLIENT_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -lreadline -lncurses
- @MONITOR_TRUE@monitor_btmon_SOURCES = monitor/main.c monitor/bt.h \
- @MONITOR_TRUE@ monitor/display.h monitor/display.c \
-@@ -2691,13 +2691,13 @@ unit_tests = $(am__append_35) unit/test-
- @READLINE_TRUE@ client/display.h
+ @MESH_TRUE@mesh_meshctl_SOURCES = mesh/main.c \
+ @MESH_TRUE@ mesh/mesh-net.h \
+@@ -2468,7 +2468,7 @@
- @READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
--@READLINE_TRUE@ src/libshared-glib.la @GLIB_LIBS@ -lreadline
-+@READLINE_TRUE@ src/libshared-glib.la @GLIB_LIBS@ -lreadline -lncurses
+ @MESH_TRUE@mesh_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
+ @MESH_TRUE@ lib/libbluetooth-internal.la \
+-@MESH_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -ljson-c -lreadline
++@MESH_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -ljson-c -lreadline -lncurses
- @READLINE_TRUE@tools_obex_client_tool_SOURCES = $(gobex_sources) $(btio_sources) \
+ @MONITOR_TRUE@monitor_btmon_SOURCES = monitor/main.c monitor/bt.h \
+ @MONITOR_TRUE@ monitor/display.h monitor/display.c \
+@@ -2724,7 +2724,7 @@
@READLINE_TRUE@ tools/obex-client-tool.c
@READLINE_TRUE@tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \
@@ -25,7 +27,7 @@
@READLINE_TRUE@tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \
@READLINE_TRUE@ tools/obex-server-tool.c
-@@ -2707,17 +2707,17 @@ unit_tests = $(am__append_35) unit/test-
+@@ -2734,17 +2734,17 @@
@READLINE_TRUE@ client/display.h client/display.c
@READLINE_TRUE@tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \
@@ -44,5 +46,14 @@
-@READLINE_TRUE@ -lreadline
+@READLINE_TRUE@ -lreadline -lncurses
- @EXPERIMENTAL_TRUE@tools_gatt_service_SOURCES = tools/gatt-service.c
- @EXPERIMENTAL_TRUE@tools_gatt_service_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ gdbus/libgdbus-internal.la
+ @DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_SOURCES = attrib/gatttool.c attrib/att.c attrib/gatt.c \
+ @DEPRECATED_TRUE@@READLINE_TRUE@ attrib/gattrib.c btio/btio.c \
+@@ -2753,7 +2753,7 @@
+ @DEPRECATED_TRUE@@READLINE_TRUE@ client/display.h
+
+ @DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
+-@DEPRECATED_TRUE@@READLINE_TRUE@ src/libshared-glib.la @GLIB_LIBS@ -lreadline
++@DEPRECATED_TRUE@@READLINE_TRUE@ src/libshared-glib.la @GLIB_LIBS@ -lreadline -lncurses
+
+ @CUPS_TRUE@cupsdir = $(libdir)/cups/backend
+ @CUPS_TRUE@profiles_cups_bluetooth_SOURCES = profiles/cups/main.c \