aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/python/python/files/python-package.mk2
-rw-r--r--lang/python/python3/Makefile2
-rw-r--r--lang/python/python3/files/python3-package-pip.mk3
-rw-r--r--lang/python/python3/files/python3-package-setuptools.mk1
-rw-r--r--lang/python/python3/files/python3-package.mk2
5 files changed, 8 insertions, 2 deletions
diff --git a/lang/python/python/files/python-package.mk b/lang/python/python/files/python-package.mk
index e9ec85c6f..0805fc9c2 100644
--- a/lang/python/python/files/python-package.mk
+++ b/lang/python/python/files/python-package.mk
@@ -61,6 +61,7 @@ define PyPackage
endef
endif
+ ifndef Package/$(1)/install
$(call shexport,PyPackage/$(1)/filespec)
define Package/$(1)/install
@@ -85,6 +86,7 @@ define PyPackage
define Package/$(1)-src/install
$$(call Package/$(1)/install,$$(1),sources)
endef
+ endif # Package/$(1)/install
endef
$(call include_mk, python-host.mk)
diff --git a/lang/python/python3/Makefile b/lang/python/python3/Makefile
index 584dcbb5f..97c0f6efe 100644
--- a/lang/python/python3/Makefile
+++ b/lang/python/python3/Makefile
@@ -14,7 +14,7 @@ PYTHON_VERSION:=$(PYTHON3_VERSION)
PYTHON_VERSION_MICRO:=$(PYTHON3_VERSION_MICRO)
PKG_NAME:=python3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
diff --git a/lang/python/python3/files/python3-package-pip.mk b/lang/python/python3/files/python3-package-pip.mk
index 0bd54aac8..43e05f1c7 100644
--- a/lang/python/python3/files/python3-package-pip.mk
+++ b/lang/python/python3/files/python3-package-pip.mk
@@ -12,7 +12,7 @@ $(call Package/python3/Default)
DEPENDS:=+python3 +python3-setuptools +python-pip-conf
endef
-define Py3Package/python3-pip/install
+define Package/python3-pip/install
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib/python$(PYTHON3_VERSION)/site-packages
# Adjust shebang to proper python location on target
sed "1s/.*/#\!\/usr\/bin\/python$(PYTHON3_VERSION)/" -i $(PKG_BUILD_DIR)/install-pip/bin/*
@@ -20,6 +20,7 @@ define Py3Package/python3-pip/install
$(CP) \
$(PKG_BUILD_DIR)/install-pip/lib/python$(PYTHON3_VERSION)/site-packages/pip \
$(1)/usr/lib/python$(PYTHON3_VERSION)/site-packages/
+ find $(1)/usr/lib/python$(PYTHON3_VERSION)/site-packages/ -name __pycache__ | xargs rm -rf
endef
$(eval $(call Py3BasePackage,python3-pip, \
diff --git a/lang/python/python3/files/python3-package-setuptools.mk b/lang/python/python3/files/python3-package-setuptools.mk
index 52d56e9ed..9a646334f 100644
--- a/lang/python/python3/files/python3-package-setuptools.mk
+++ b/lang/python/python3/files/python3-package-setuptools.mk
@@ -23,6 +23,7 @@ define Py3Package/python3-setuptools/install
$(PKG_BUILD_DIR)/install-setuptools/lib/python$(PYTHON3_VERSION)/site-packages/setuptools \
$(PKG_BUILD_DIR)/install-setuptools/lib/python$(PYTHON3_VERSION)/site-packages/easy_install.py \
$(1)/usr/lib/python$(PYTHON3_VERSION)/site-packages
+ find $(1)/usr/lib/python$(PYTHON3_VERSION)/site-packages/ -name __pycache__ | xargs rm -rf
endef
$(eval $(call Py3BasePackage,python3-setuptools, \
diff --git a/lang/python/python3/files/python3-package.mk b/lang/python/python3/files/python3-package.mk
index a28689aba..36a030c02 100644
--- a/lang/python/python3/files/python3-package.mk
+++ b/lang/python/python3/files/python3-package.mk
@@ -61,6 +61,7 @@ define Py3Package
endef
endif
+ ifndef Package/$(1)/install
$(call shexport,Py3Package/$(1)/filespec)
define Package/$(1)/install
@@ -85,6 +86,7 @@ define Py3Package
define Package/$(1)-src/install
$$(call Package/$(1)/install,$$(1),sources)
endef
+ endif # Package/$(1)/install
endef
$(call include_mk, python3-host.mk)