aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-03-02 20:12:50 -0800
committerGitHub <noreply@github.com>2021-03-02 20:12:50 -0800
commitf9ec8d411c5d5fe17367043c07e5bea5ace776b2 (patch)
tree8b58e216af5710f1e6792b032790176e6d2be6ea /utils
parent8fbff0ec6880c30d65182a938c94b7f7f160aafd (diff)
parent459aa353bb72dd3b6978b44495382eab2b15695e (diff)
Merge pull request #14943 from aTanW/master
joe: new package joe-extras
Diffstat (limited to 'utils')
-rw-r--r--utils/joe/Makefile40
1 files changed, 36 insertions, 4 deletions
diff --git a/utils/joe/Makefile b/utils/joe/Makefile
index 66843072e..8def7ab7e 100644
--- a/utils/joe/Makefile
+++ b/utils/joe/Makefile
@@ -5,10 +5,9 @@
# See /LICENSE for more information.
#
-# changes by David Kuehling <dvdkhlng TA gmx TOD de>:
+# changes by Vitaly Prosko <villy TA sft TOD ru>:
#
-# - include support for all emulation modes jmacs jpico etc.
-# - see patches/002-builtinrc.patch
+# - added new package joe-extra with all additional joe's stuff
#
# changes by Vitaly Prosko <villy TA sft TOD ru>:
#
@@ -21,7 +20,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=joe
PKG_VERSION:=4.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/joe-editor
@@ -42,11 +41,24 @@ define Package/joe
DEPENDS:=+libncurses
endef
+define Package/joe-extras
+ SECTION:=utils
+ CATEGORY:=Utilities
+ SUBMENU:=Editors
+ TITLE:=Extra data for JOE - Joes own editor
+ URL:=https://sourceforge.net/projects/joe-editor/
+ DEPENDS:=+joe
+endef
+
define Package/joe/description
Joe is world-famous Wordstar like text editor, that also features
Emacs and Pico emulation
endef
+define Package/joe-extras/description
+Additional data for full Joe editor functionality
+endef
+
define Package/joe/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/joe/joe $(1)/usr/bin/
@@ -54,8 +66,28 @@ define Package/joe/install
$(INSTALL_CONF) ./files/joerc $(1)/etc/joe/joerc
endef
+define Package/joe-extras/install
+ $(INSTALL_DIR) $(1)/etc/joe
+ $(INSTALL_DIR) $(1)/usr/share/joe/{syntax,lang,charmaps,colors}
+ $(INSTALL_CONF) $(PKG_BUILD_DIR)/rc/{ftyperc,jicerc.ru,jmacsrc,jpicorc,jstarrc,rjoerc} $(1)/etc/joe/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/syntax/*.jsf $(1)/usr/share/joe/syntax/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/po/*.po $(1)/usr/share/joe/lang/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/charmaps/klingon $(1)/usr/share/joe/charmaps/
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/colors/*.jcf $(1)/usr/share/joe/colors/
+endef
+
define Package/joe/conffiles
/etc/joe/joerc
endef
+define Package/joe-extras/conffiles
+/etc/joe/ftype
+/etc/joe/jicerc.ru
+/etc/joe/jmacsrc
+/etc/joe/jpicorc
+/etc/joe/jstarrc
+/etc/joe/rjoerc
+endef
+
$(eval $(call BuildPackage,joe))
+$(eval $(call BuildPackage,joe-extras))