aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2018-07-08 09:54:28 +0200
committerSebastian Kemper <sebastian_ml@gmx.net>2018-07-08 09:54:35 +0200
commitf7272222218c360740e55c91b15530e54f494a6b (patch)
treede2f4ff511ff6198c09ae5d6f6452fec8d236648 /utils
parente63960f24e15b692ab3ed3cf5c0517039c45e367 (diff)
mariadb: fix CPPFLAGS handling
The mariadb build system ignores CPPFLAGS. Add them to CFLAGS as a workaround. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'utils')
-rw-r--r--utils/mariadb/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/utils/mariadb/Makefile b/utils/mariadb/Makefile
index 439ec941f..e32c20b43 100644
--- a/utils/mariadb/Makefile
+++ b/utils/mariadb/Makefile
@@ -174,6 +174,10 @@ include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/cmake.mk
+# Pass CPPFLAGS in the CFLAGS as otherwise the build system will
+# ignore them.
+TARGET_CFLAGS+=$(TARGET_CPPFLAGS)
+
define Package/mariadb/install/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(2) $(1)/usr/bin
endef