aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2015-09-30 12:35:02 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2015-09-30 12:35:02 -0700
commitedacac23e05b9effef9aa1e9e4164899b96f9fc1 (patch)
treec640d0f144735b3f83bf03f2fbbd1b11f4bca982 /utils
parent52e2f0e80b8c6c907543be2f96ed476440669731 (diff)
parent0353388819d2beb1e494346d15b6444c204347a3 (diff)
Merge pull request #1797 from mhei/fix-open-plc-utils
open-plc-utils: upgrade to latest git revision and fix compilation
Diffstat (limited to 'utils')
-rw-r--r--utils/open-plc-utils/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/utils/open-plc-utils/Makefile b/utils/open-plc-utils/Makefile
index 74a9f995f..1017ee88c 100644
--- a/utils/open-plc-utils/Makefile
+++ b/utils/open-plc-utils/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=open-plc-utils
-PKG_VERSION:=2015-07-06
+PKG_VERSION:=2015-09-21
PKG_RELEASE:=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://github.com/qca/open-plc-utils.git
+PKG_SOURCE_URL:=https://github.com/qca/open-plc-utils.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=885a1b7e2e663b5ab8797db6d40a0318131fdf18
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
@@ -75,6 +75,10 @@ OPEN_PLC_UTILS_APPS:=efbu efeu efru efsu edru edsu nics \
$(foreach a,$(OPEN_PLC_UTILS_APPS),$(eval $(call GenPlugin,$(a))))
+ifdef CONFIG_USE_MUSL
+ TARGET_CFLAGS += -D__UCLIBC__
+endif
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
EXTRA_CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \