aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-08-09 09:16:13 -0700
committerGitHub <noreply@github.com>2019-08-09 09:16:13 -0700
commite91ef90bb2b62520003a5bddad2ffea5ed4a8c93 (patch)
treea245ca98a7ecd3c254bb0b26401f919e7d3681c2 /utils
parenteeab57d16ab473a0695f4a7906525435aca834e7 (diff)
parentfa40b85f20f697e4c0b7b96b77b3a40902c72605 (diff)
Merge pull request #9674 from neheb/lcd2
lcdproc: Fix non x86 platforms on musl
Diffstat (limited to 'utils')
-rw-r--r--utils/lcdproc/Makefile14
-rw-r--r--utils/lcdproc/patches/110-in-outb.patch11
2 files changed, 14 insertions, 11 deletions
diff --git a/utils/lcdproc/Makefile b/utils/lcdproc/Makefile
index 0260cf4a4..00fd460ba 100644
--- a/utils/lcdproc/Makefile
+++ b/utils/lcdproc/Makefile
@@ -9,18 +9,17 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lcdproc
PKG_VERSION:=0.5.9
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/lcdproc/lcdproc/releases/download/v$(PKG_VERSION)/
PKG_HASH:=d48a915496c96ff775b377d2222de3150ae5172bfb84a6ec9f9ceab962f97b83
+
PKG_MAINTAINER:=Harald Geyer <harald@ccbib.org>, \
Philip Prindeville <philipp@redfish-solutions.com>
-PKG_LICENSE:=GPL-2.0
+PKG_LICENSE:=GPL-2.0-only
PKG_LICENSE_FILES:=COPYING
-PKG_FIXUP:=autoreconf
-
include $(INCLUDE_DIR)/package.mk
define Package/lcdproc/Default
@@ -109,10 +108,6 @@ This package contains display drivers with external dependencies:
$(LCDPROC_OTHER_DRIVERS_TEXT)
endef
-
-# not everything groks --disable-nls
-DISABLE_NLS:=
-
CONFIGURE_ARGS += \
--disable-libX11 \
--disable-libhid \
@@ -120,9 +115,6 @@ CONFIGURE_ARGS += \
--disable-freetype \
--enable-drivers='all,!g15,!g15driver,!glcdlib,!irman,!lirc,!mdm166a,!mx5000,!svga,!xosd'
-# can't use -Wformat=2 because MUSL is somewhat broken
-TARGET_CFLAGS+=-Wall
-
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)"
diff --git a/utils/lcdproc/patches/110-in-outb.patch b/utils/lcdproc/patches/110-in-outb.patch
new file mode 100644
index 000000000..7bf34eb30
--- /dev/null
+++ b/utils/lcdproc/patches/110-in-outb.patch
@@ -0,0 +1,11 @@
+--- a/server/drivers/port.h
++++ b/server/drivers/port.h
+@@ -94,7 +94,7 @@ static inline int port_deny_multiple(unsigned short port, unsigned short count);
+ /* ---------------------------- Linux ------------------------------------ */
+ /* Use ioperm, inb and outb in <sys/io.h> (Linux) */
+ /* And iopl for higher addresses of PCI LPT cards */
+-#if defined HAVE_IOPERM
++#if defined(__GLIBC__) || (defined(__x86__) || defined(__x86_64__))
+
+ /* Glibc2 and Glibc1 */
+ # ifdef HAVE_SYS_IO_H