aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2014-06-14 20:12:56 +0200
committerSteven Barth <steven@midlink.org>2014-06-14 20:13:49 +0200
commite61b36871d0f3a43fdf448c497b959ffab8e91bd (patch)
treec7fda67b869f234eab1d597f052e64f734d2d80b /utils
parentc56566c6ef5b0dff3839e4177a5fb0437b771e49 (diff)
unzip: fix cross-compilation and skip target checks
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> Signed-off-by: Steven Barth <steven@midlink.org>
Diffstat (limited to 'utils')
-rw-r--r--utils/unzip/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/utils/unzip/Makefile b/utils/unzip/Makefile
index 1628d0406..441b4835e 100644
--- a/utils/unzip/Makefile
+++ b/utils/unzip/Makefile
@@ -43,12 +43,15 @@ endef
define Build/Configure
endef
+TARGET_CFLAGS += -DNO_LCHMOD -DLARGE_FILE_SUPPORT
+
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) -f unix/Makefile generic \
+ $(MAKE) -C $(PKG_BUILD_DIR) -f unix/Makefile unzips \
$(TARGET_CONFIGURE_OPTS) \
prefix="$(PKG_INSTALL_DIR)/usr" \
CFLAGS="$(TARGET_CFLAGS)" \
CF="$(TARGET_CFLAGS) -O $(TARGET_CPPFLAGS) -I. -DUNIX" \
+ CC="$(TARGET_CC)" \
LD="$(TARGET_CC) $(TARGET_LDFLAGS)" \
install
endef