aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2019-01-06 08:45:07 +0100
committerGitHub <noreply@github.com>2019-01-06 08:45:07 +0100
commite53aadba0d351737a048a4c623375f060e5725e9 (patch)
tree49827709617424b51956af50f089f747a2797974 /utils
parent7696b4ec63f0f146e5371d2ef119d7a9c95c3746 (diff)
parent969b6df4428db418caacea5481e3e6dbfb9bfd9e (diff)
Merge pull request #7650 from mhei/open-plc-utils-missing-tools
open-plc-utils: package missing tools amprule, pev and evse
Diffstat (limited to 'utils')
-rw-r--r--utils/open-plc-utils/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/utils/open-plc-utils/Makefile b/utils/open-plc-utils/Makefile
index 6df0adc28..1c721a1dc 100644
--- a/utils/open-plc-utils/Makefile
+++ b/utils/open-plc-utils/Makefile
@@ -8,15 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=open-plc-utils
-PKG_VERSION:=2018-11-03
-PKG_RELEASE:=$(PKG_SOURCE_VERSION)
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/qca/open-plc-utils.git
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=32408520fcebe785983a68e39ec83830a3005779
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
-PKG_MIRROR_HASH:=1c5a2bb75550f1d7069f857c30f1f45ccfd3b0b0e9abadbca10f4df582f51d1c
+PKG_MIRROR_HASH:=b5ae48fd300f75b948a2b2a5f6cd4465b7a336495685f73100ad33a5d43a4c05
PKG_MAINTAINER:=Florian Fainelli <florian@openwrt.org>
@@ -46,9 +43,9 @@ define GenPlugin
TITLE:=Utility $(1) from the Open PLC utilities
endef
- define Package/$(addprefix open-plc-utils-,$(1))/description
- Utility $(1) from the Open PLC utilities package.
- endef
+ define Package/$(addprefix open-plc-utils-,$(1))/description
+ Utility $(1) from the Open PLC utilities package.
+ endef
endef
OPEN_PLC_UTILS_APPS:=efbu efeu efru efsu edru edsu nics \
@@ -64,7 +61,7 @@ OPEN_PLC_UTILS_APPS:=efbu efeu efru efsu edru edsu nics \
int6kmdio2 int6kmod int6kstat int6ktest int6krate \
int6krule int6ktone int6kwait CMEncrypt sada \
coqos_add coqos_info coqos_man coqos_mod coqos_rel \
- mdustats ampboot amphost ampID amplist amprate \
+ mdustats ampboot amphost ampID amplist amprate amprule \
ampstat amptest amptool amptone ampwait \
plcboot plchost plcID plclist plcrate plcrule \
plcstat plctest plctool plctone \
@@ -72,7 +69,8 @@ OPEN_PLC_UTILS_APPS:=efbu efeu efru efsu edru edsu nics \
plcdevs plclog plcmdio16 plcmdio32 \
config2cfg sdram \
int6kuart int6kbaud ttysig ptsctl weeder ttysend \
- ttyrecv ttycat int6kdetect
+ ttyrecv ttycat int6kdetect \
+ pev evse
$(foreach a,$(OPEN_PLC_UTILS_APPS),$(eval $(call GenPlugin,$(a))))
@@ -93,7 +91,7 @@ endef
define BuildPlugin
define Package/$(1)/install
- $(INSTALL_DIR) $$(1)/usr/bin
+ $(INSTALL_DIR) $$(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/local/bin/$(subst open-plc-utils-,,$(1)) \
$$(1)/usr/bin/
endef