aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-07-15 12:51:43 -0700
committerRosen Penev <rosenp@gmail.com>2019-07-15 12:51:43 -0700
commitdb6e6ac24a60377dd963be1aef1c1f48dea316d7 (patch)
tree22d53e6c3849280b4d2ba1be5198b813525bdf87 /utils
parentd53191e3f9921d2b316bc9388221e9fbeeecb4a4 (diff)
ykpers: Update to 1.20.0
Cleaned up Makefile for consistency between packages. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/ykpers/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/utils/ykpers/Makefile b/utils/ykpers/Makefile
index c2bd1e7c1..1c883af64 100644
--- a/utils/ykpers/Makefile
+++ b/utils/ykpers/Makefile
@@ -1,23 +1,21 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ykpers
-PKG_VERSION:=1.19.0
+PKG_VERSION:=1.20.0
PKG_RELEASE:=1
-PKG_SOURCE:=ykpers-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://developers.yubico.com/yubikey-personalization/Releases
-PKG_HASH:=2bc8afa16d495a486582bad916d16de1f67c0cce9bb0a35c3123376c2d609480
+PKG_HASH:=0ec84d0ea862f45a7d85a1a3afe5e60b8da42df211bb7d27a50f486e31a79b93
+
PKG_MAINTAINER:=Stuart B. Wilkins <stuwilkins@mac.com>
-PKG_LICENSE_FILES:=COPYING
PKG_LICENSE:=BSD-2-Clause
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/ykpers-$(PKG_VERSION)
-PKG_BUILD_DEPENDS:=libyubikey
+PKG_LICENSE_FILES:=COPYING
include $(INCLUDE_DIR)/package.mk
define Package/ykpers
- SECTION:=utils
+ SECTION:=utils
CATEGORY:=Utilities
TITLE:=The Yuibco personalization package
URL:=https://developers.yubico.com/yubikey-personalization/
@@ -25,7 +23,7 @@ define Package/ykpers
endef
define Package/ykpers/description
- The YubiKey Personalization package contains a library and command
+ The YubiKey Personalization package contains a library and command
line tool used to personalize (i.e., set a AES key) YubiKeys.
endef
@@ -33,7 +31,6 @@ CONFIGURE_ARGS += \
--enable-shared \
--disable-static
-
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR)/usr/include
$(CP) $(PKG_BUILD_DIR)/ykcore/*.h $(STAGING_DIR)/usr/include