aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2017-11-06 23:01:38 +0100
committerDaniel Golle <daniel@makrotopia.org>2017-11-07 01:30:02 +0100
commitd947a6cd79a4c7757b30b946245e6036a129b59e (patch)
tree0b636d609667a856f11acb8bcf0b20a4cac8fa84 /utils
parentd7253f8bcb2ba3b66d12507ef491295c0240f310 (diff)
lvm2: update to version 2.02.176
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'utils')
-rw-r--r--utils/lvm2/Makefile4
-rw-r--r--utils/lvm2/patches/000-compile.patch2
-rw-r--r--utils/lvm2/patches/002-const-stdio.patch8
3 files changed, 7 insertions, 7 deletions
diff --git a/utils/lvm2/Makefile b/utils/lvm2/Makefile
index 1e477ef22..6e451ca84 100644
--- a/utils/lvm2/Makefile
+++ b/utils/lvm2/Makefile
@@ -9,14 +9,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=LVM2
-PKG_VERSION:=2.02.168
+PKG_VERSION:=2.02.176
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0 LGPL-2.1
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
PKG_SOURCE_URL:=ftp://sources.redhat.com/pub/lvm2/releases \
http://ftp.gwdg.de/pub/linux/sources.redhat.com/lvm2/
-PKG_HASH:=23a3d1cddd41b3ef51812ebf83e9fa491f502fe74130d4263be327a91914660d
+PKG_HASH:=dece83628c2c78a267a126ce6046d506582185ae5d40fb8d59b56547fccea473
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME).$(PKG_VERSION)
diff --git a/utils/lvm2/patches/000-compile.patch b/utils/lvm2/patches/000-compile.patch
index 9fa1c1d56..0ba1c9b76 100644
--- a/utils/lvm2/patches/000-compile.patch
+++ b/utils/lvm2/patches/000-compile.patch
@@ -1,6 +1,6 @@
--- a/make.tmpl.in
+++ b/make.tmpl.in
-@@ -19,7 +19,7 @@ SHELL = /bin/sh
+@@ -19,7 +19,7 @@ SHELL = @SHELL@
# Allow environment to override any built-in default value for CC.
# If there is a built-in default, CC is NOT set to @CC@ here.
diff --git a/utils/lvm2/patches/002-const-stdio.patch b/utils/lvm2/patches/002-const-stdio.patch
index 546a03cb2..1db823477 100644
--- a/utils/lvm2/patches/002-const-stdio.patch
+++ b/utils/lvm2/patches/002-const-stdio.patch
@@ -1,6 +1,6 @@
--- a/lib/commands/toolcontext.c
+++ b/lib/commands/toolcontext.c
-@@ -1843,7 +1843,7 @@ struct cmd_context *create_toolcontext(u
+@@ -1869,7 +1869,7 @@ struct cmd_context *create_toolcontext(u
/* FIXME Make this configurable? */
reset_lvm_errno(1);
@@ -9,7 +9,7 @@
/* Set in/out stream buffering before glibc */
if (set_buffering) {
/* Allocate 2 buffers */
-@@ -2224,7 +2224,7 @@ void destroy_toolcontext(struct cmd_cont
+@@ -2249,7 +2249,7 @@ void destroy_toolcontext(struct cmd_cont
if (cmd->libmem)
dm_pool_destroy(cmd->libmem);
@@ -20,7 +20,7 @@
if (is_valid_fd(STDIN_FILENO) &&
--- a/tools/lvmcmdline.c
+++ b/tools/lvmcmdline.c
-@@ -1815,6 +1815,7 @@ int lvm_split(char *str, int *argc, char
+@@ -3074,6 +3074,7 @@ int lvm_split(char *str, int *argc, char
/* Make sure we have always valid filedescriptors 0,1,2 */
static int _check_standard_fds(void)
{
@@ -28,7 +28,7 @@
int err = is_valid_fd(STDERR_FILENO);
if (!is_valid_fd(STDIN_FILENO) &&
-@@ -1841,6 +1842,12 @@ static int _check_standard_fds(void)
+@@ -3100,6 +3101,12 @@ static int _check_standard_fds(void)
strerror(errno));
return 0;
}