aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2020-03-14 19:05:27 +0200
committerGitHub <noreply@github.com>2020-03-14 19:05:27 +0200
commitd730fd501a2cc2759b9492778d5fd81308f529fe (patch)
tree87388bd90d3ef39f26149500902a3f9e2129a6ee /utils
parent1fa9ca064d4609ce774e2b5c66a740af086abffa (diff)
parent90ef59eab7631b38669c5988a34b0c24b02517c8 (diff)
Merge pull request #11569 from G-M0N3Y-2503/feature_docker-ce_update
docker-ce: Updated to 19.03.8 and updated relevant dependencies
Diffstat (limited to 'utils')
-rw-r--r--utils/containerd/Makefile8
-rw-r--r--utils/docker-ce/Makefile12
-rw-r--r--utils/libnetwork/Makefile8
-rw-r--r--utils/runc/Makefile12
4 files changed, 19 insertions, 21 deletions
diff --git a/utils/containerd/Makefile b/utils/containerd/Makefile
index 8437ce8e8..3da8c8cb3 100644
--- a/utils/containerd/Makefile
+++ b/utils/containerd/Makefile
@@ -1,15 +1,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=containerd
-PKG_VERSION:=1.2.10
-PKG_RELEASE:=4
+PKG_VERSION:=1.2.13
+PKG_RELEASE:=1
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/containerd/containerd/tar.gz/v${PKG_VERSION}?
-PKG_HASH:=a0965e1492fca558629826f1aa89a9675de3d451cec67540400b30c0bf6ac387
-PKG_SOURCE_VERSION:=b34a5c8af56e510852c35414db4c1f4fa6172339
+PKG_HASH:=0811057ab67b78ce911416e793edaeb14b3f1e105d67b8e67b6302e0eab572e4
+PKG_SOURCE_VERSION:=7ad184331fa3e55e52b890ea95e65ba581ae3429
PKG_MAINTAINER:=Gerard Ryan <G.M0N3Y.2503@gmail.com>
diff --git a/utils/docker-ce/Makefile b/utils/docker-ce/Makefile
index 6d4acc2a6..adbaa6b7c 100644
--- a/utils/docker-ce/Makefile
+++ b/utils/docker-ce/Makefile
@@ -1,15 +1,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=docker-ce
-PKG_VERSION:=19.03.5
+PKG_VERSION:=19.03.8
PKG_RELEASE:=2
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=components/cli/LICENSE components/engine/LICENSE
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/docker/docker-ce/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=d7948256e32bb4c104285d78e652ba9ead898c2e4dcee05f05ede2eaba719919
-PKG_SOURCE_VERSION:=633a0ea838 # SHA1 used within the docker executables
+PKG_HASH:=781c69e00e98f64fb167ee61de764882bd4926a873d98ce6f370d3cd3435b501
+PKG_SOURCE_VERSION:=afacb8b7f0 # SHA1 used within the docker executables
PKG_MAINTAINER:=Gerard Ryan <G.M0N3Y.2503@gmail.com>
@@ -22,9 +22,9 @@ define CheckExpectedSrcVer
endef
# values from respective '.installer' files at https://github.com/docker/docker-ce/blob/v$(PKG_VERSION)/components/engine/hack/dockerfile/install/
-$(eval $(call CheckExpectedSrcVer,../containerd/Makefile,b34a5c8af56e510852c35414db4c1f4fa6172339))
-$(eval $(call CheckExpectedSrcVer,../libnetwork/Makefile,3eb39382bfa6a3c42f83674ab080ae13b0e34e5d))
-$(eval $(call CheckExpectedSrcVer,../runc/Makefile,3e425f80a8c931f88e6d94a8c831b9d5aa481657))
+$(eval $(call CheckExpectedSrcVer,../containerd/Makefile,7ad184331fa3e55e52b890ea95e65ba581ae3429))
+$(eval $(call CheckExpectedSrcVer,../libnetwork/Makefile,9fd385be8302dbe1071a3ce124891893ff27f90f))
+$(eval $(call CheckExpectedSrcVer,../runc/Makefile,dc9208a3303feef5b3839f4323d9beb36df0a9dd))
$(eval $(call CheckExpectedSrcVer,../tini/Makefile,fec3683b971d9c3ef73f284f176672c44b448662))
PKG_BUILD_DEPENDS:=golang/host
diff --git a/utils/libnetwork/Makefile b/utils/libnetwork/Makefile
index ba583f25c..2c7377852 100644
--- a/utils/libnetwork/Makefile
+++ b/utils/libnetwork/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libnetwork
-PKG_RELEASE:=3
+PKG_RELEASE:=1
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
@@ -12,9 +12,9 @@ GO_PKG_BUILD_PKG:= \
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://$(GO_PKG)
-PKG_SOURCE_VERSION:=3eb39382bfa6a3c42f83674ab080ae13b0e34e5d
-PKG_SOURCE_DATE:=2019-10-22
-PKG_MIRROR_HASH:=0c2e3c83559b9ac27d2ef953911400957c8634847038c9da83a1fd8769a37a8d
+PKG_SOURCE_VERSION:=9fd385be8302dbe1071a3ce124891893ff27f90f
+PKG_SOURCE_DATE:=2020-01-03
+PKG_MIRROR_HASH:=16cea9d9978b11869029bc9ae0da533c2d7fdf4b9c1f7905bf6c98f443347831
PKG_MAINTAINER:=Gerard Ryan <G.M0N3Y.2503@gmail.com>
diff --git a/utils/runc/Makefile b/utils/runc/Makefile
index e8cb4140a..eef25fa8e 100644
--- a/utils/runc/Makefile
+++ b/utils/runc/Makefile
@@ -1,17 +1,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=runc
-PKG_VERSION:=1.0.0-rc8+91-3e425f80
-PKG_RELEASE:=4
+PKG_VERSION:=1.0.0-rc10
+PKG_RELEASE:=1
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/opencontainers/runc
-PKG_MIRROR_HASH:=11dce499b6fbdb159d2ef64b0e9b719ccdf6c59ca1cc7ac0026b1d58547fc187
-PKG_SOURCE_VERSION:=3e425f80a8c931f88e6d94a8c831b9d5aa481657
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2019-10-15
+PKG_SOURCE_URL:=https://codeload.github.com/opencontainers/runc/tar.gz/v${PKG_VERSION}?
+PKG_HASH:=6b44985023347fb9c5a2cc6f761df8c41cc2c84a7a68a6e6acf834dff6653a9a
+PKG_SOURCE_VERSION:=dc9208a3303feef5b3839f4323d9beb36df0a9dd
PKG_MAINTAINER:=Gerard Ryan <G.M0N3Y.2503@gmail.com>