aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-18 12:08:40 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-18 12:10:44 +0100
commitd548d6bf1fc41718d7962111d44e011bcad8dc02 (patch)
treef332eb25114595780e7a165ea023734e934bdc55 /utils
parentb85f3d20b71a9d070dcf36f83ce6eed585dfa4cf (diff)
coreutils: add libcap dependency to selected applets
If libcap happens to be present in the environment, coreutils will pick it up and link some applets against it. Since the idea of coreutils is to provide a full featured alternative to the busybox applets, do not inhibit the optional dependency but explicitely require libcap instead. Fixes the following error spotted on the buildbots: Package coreutils-dir is missing dependencies for the following libraries: libcap.so.2 Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'utils')
-rw-r--r--utils/coreutils/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/utils/coreutils/Makefile b/utils/coreutils/Makefile
index 73b1a85f7..0d52b60ea 100644
--- a/utils/coreutils/Makefile
+++ b/utils/coreutils/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=coreutils
PKG_VERSION:=8.23
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/coreutils
@@ -37,11 +37,11 @@ DEPENDS_timeout = +librt
DEPENDS_expr = +libgmp
DEPENDS_factor = +libgmp
DEPENDS_cp = +libacl
-DEPENDS_dir = +libacl
+DEPENDS_dir = +libacl +libcap
DEPENDS_install = +libacl
-DEPENDS_ls = +libacl
+DEPENDS_ls = +libacl +libcap
DEPENDS_mv = +libacl
-DEPENDS_vdir = +libacl
+DEPENDS_vdir = +libacl +libcap
define Package/coreutils/Default
SECTION:=utils