aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-06-10 01:58:56 -0700
committerGitHub <noreply@github.com>2020-06-10 01:58:56 -0700
commitce744f698590280f4ed3e8a2cdeda17cf6a0add0 (patch)
tree412d64201721197ec64df69fbf1c16a62d61e71e /utils
parent24c822d746d3b7675925b4f0474791c4ddcd40aa (diff)
parent8a2420a251c275c420a557d9bb30c46e14350ba3 (diff)
Merge pull request #12468 from zhanhb/kmod-alternatives
kmod: add ALTERNATIVES
Diffstat (limited to 'utils')
-rw-r--r--utils/kmod/Makefile21
1 files changed, 8 insertions, 13 deletions
diff --git a/utils/kmod/Makefile b/utils/kmod/Makefile
index b9e7b6068..ecd7e3d6d 100644
--- a/utils/kmod/Makefile
+++ b/utils/kmod/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=kmod
PKG_VERSION:=20
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/kernel/kmod/
@@ -32,6 +32,13 @@ define Package/kmod/Default
TITLE:=Linux kernel module handling
URL:=https://www.kernel.org/pub/linux/utils/kernel/kmod/
DEPENDS:=+zlib
+ ALTERNATIVES:=\
+ 200:/sbin/depmod:/sbin/kmod \
+ 200:/sbin/insmod:/sbin/kmod \
+ 200:/sbin/lsmod:/sbin/kmod \
+ 200:/sbin/modinfo:/sbin/kmod \
+ 200:/sbin/modprobe:/sbin/kmod \
+ 200:/sbin/rmmod:/sbin/kmod
endef
@@ -46,21 +53,9 @@ Linux kernel module handling
insert, remove, list, check properties, resolve dependencies and aliases.
endef
-LEGACY_BINARIES:= \
- depmod \
- insmod \
- lsmod \
- modinfo \
- modprobe \
- rmmod
-
define Package/kmod/install
$(INSTALL_DIR) $(1)/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/kmod $(1)/sbin
-
- for b in $(LEGACY_BINARIES); do \
- ln -sf kmod $(1)/sbin/$$$$b ; \
- done
endef