aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorGerard Ryan <G.M0N3Y.2503@gmail.com>2019-08-03 19:43:06 +1000
committerYousong Zhou <yszhou4tech@gmail.com>2019-08-10 15:44:29 +0800
commitc92f7c2006091079e51f718c4b4b5a0512870e85 (patch)
treeb4636bfd21e42439f21b908ed1acc95732de384a /utils
parent7fe591cac635187e46dae6b9c72cfcf4b28fd930 (diff)
docker-ce: Updated to 19.03.1
Signed-off-by: Gerard Ryan <G.M0N3Y.2503@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/docker-ce/Makefile11
-rw-r--r--utils/docker-ce/files/daemon.json3
-rw-r--r--utils/docker-ce/files/dockerd.init3
3 files changed, 11 insertions, 6 deletions
diff --git a/utils/docker-ce/Makefile b/utils/docker-ce/Makefile
index 6518dee81..ced993ad3 100644
--- a/utils/docker-ce/Makefile
+++ b/utils/docker-ce/Makefile
@@ -1,15 +1,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=docker-ce
-PKG_VERSION:=18.09.8
+PKG_VERSION:=19.03.1
PKG_RELEASE:=1
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=components/cli/LICENSE components/engine/LICENSE
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/docker/docker-ce/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=33dfaf3cf296f8e9011ec6ed2de0125dfeaf8a938126f0218b0218a156c14014
-PKG_SOURCE_VERSION:=0dd43dd87f
+PKG_HASH:=dad9123e203751ce9981bc34773721593655231c32412e310e748b18f10f0053
+PKG_SOURCE_VERSION:=74b1e89e8a
PKG_MAINTAINER:=Gerard Ryan <G.M0N3Y.2503@gmail.com>
@@ -23,7 +23,7 @@ endef
# values from respective '.installer' files at https://github.com/docker/docker-ce/blob/v$(PKG_VERSION)/components/engine/hack/dockerfile/install/
$(eval $(call CheckExpectedSrcVer,../containerd/Makefile,894b81a4b802e4eb2a91d1ce216b8817763c29fb))
-$(eval $(call CheckExpectedSrcVer,../libnetwork/Makefile,e7933d41e7b206756115aa9df5e0599fc5169742))
+$(eval $(call CheckExpectedSrcVer,../libnetwork/Makefile,fc5a7d91d54cc98f64fc28f9e288b46a0bee756c))
$(eval $(call CheckExpectedSrcVer,../runc/Makefile,425e105d5a03fabd737a126ad93d62a9eeede87f))
$(eval $(call CheckExpectedSrcVer,../tini/Makefile,fec3683b971d9c3ef73f284f176672c44b448662))
@@ -116,6 +116,9 @@ define Package/docker-ce/install
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/dockerd.init $(1)/etc/init.d/dockerd
+
+ $(INSTALL_DIR) $(1)/etc/docker
+ $(INSTALL_CONF) ./files/daemon.json $(1)/etc/docker/
endef
$(eval $(call BuildPackage,docker-ce))
diff --git a/utils/docker-ce/files/daemon.json b/utils/docker-ce/files/daemon.json
new file mode 100644
index 000000000..4084c23a0
--- /dev/null
+++ b/utils/docker-ce/files/daemon.json
@@ -0,0 +1,3 @@
+{
+ "data-root": "/opt/docker/"
+}
diff --git a/utils/docker-ce/files/dockerd.init b/utils/docker-ce/files/dockerd.init
index bf1bd8ab6..d53c17178 100644
--- a/utils/docker-ce/files/dockerd.init
+++ b/utils/docker-ce/files/dockerd.init
@@ -3,9 +3,8 @@
USE_PROCD=1
START=25
-# docker can't run with a symlink in the path so we just use /opt/docker/
start_service() {
procd_open_instance
- procd_set_param command /usr/bin/dockerd -g /opt/docker/
+ procd_set_param command /usr/bin/dockerd
procd_close_instance
}