aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-05-11 16:42:17 -0700
committerRosen Penev <rosenp@gmail.com>2019-05-12 00:34:51 -0700
commitc201e5814585fe75ee7034d501752ede92afacd8 (patch)
tree45e043571e8ca88029daf964de2a0560c0c5ea42 /utils
parent6d6bceed8cf6d38a98d6464cdb62a513ba6554f9 (diff)
oath-toolkit: Fix compilation with uClibc-ng
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils')
-rw-r--r--utils/oath-toolkit/Makefile2
-rw-r--r--utils/oath-toolkit/patches/oath-toolkit-2.6.2-build-fix.patch22
2 files changed, 1 insertions, 23 deletions
diff --git a/utils/oath-toolkit/Makefile b/utils/oath-toolkit/Makefile
index ebee904d6..6ab25ce5e 100644
--- a/utils/oath-toolkit/Makefile
+++ b/utils/oath-toolkit/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=oath-toolkit
PKG_VERSION:=2.6.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=oath-toolkit-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SAVANNAH/oath-toolkit
diff --git a/utils/oath-toolkit/patches/oath-toolkit-2.6.2-build-fix.patch b/utils/oath-toolkit/patches/oath-toolkit-2.6.2-build-fix.patch
index a2fc1ad60..ff1a6ecdd 100644
--- a/utils/oath-toolkit/patches/oath-toolkit-2.6.2-build-fix.patch
+++ b/utils/oath-toolkit/patches/oath-toolkit-2.6.2-build-fix.patch
@@ -123,28 +123,6 @@ index 8ab19fd..54c3d5a 100644
return ((fp->_flags & _IO_NO_WRITES) != 0
|| ((fp->_flags & (_IO_NO_READS | _IO_CURRENTLY_PUTTING)) == 0
&& fp->_IO_read_base != NULL));
-diff --git a/liboath/gl/fseeko.c b/liboath/gl/fseeko.c
-index 67bb9ec..5616221 100644
---- a/liboath/gl/fseeko.c
-+++ b/liboath/gl/fseeko.c
-@@ -47,7 +47,7 @@ fseeko (FILE *fp, off_t offset, int whence)
- #endif
-
- /* These tests are based on fpurge.c. */
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_ftrylockfile || __GNU_LIBRARY__ /* GNU libc, BeOS, Haiku, Linux libc5 */
- if (fp->_IO_read_end == fp->_IO_read_ptr
- && fp->_IO_write_ptr == fp->_IO_write_base
- && fp->_IO_save_base == NULL)
-@@ -123,7 +123,7 @@ fseeko (FILE *fp, off_t offset, int whence)
- return -1;
- }
-
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_ftrylockfile || __GNU_LIBRARY__ /* GNU libc, BeOS, Haiku, Linux libc5 */
- fp->_flags &= ~_IO_EOF_SEEN;
- fp->_offset = pos;
- #elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
diff --git a/liboath/gl/stdio-impl.h b/liboath/gl/stdio-impl.h
index 4c02c9f..393ef0c 100644
--- a/liboath/gl/stdio-impl.h