aboutsummaryrefslogtreecommitdiff
path: root/utils
diff options
context:
space:
mode:
authorLawrence D'Anna <larry@elder-gods.org>2015-03-22 03:36:10 -0700
committerLawrence D'Anna <larry@elder-gods.org>2015-03-23 18:38:53 -0700
commitbd78782e2e949b94f7386149dacde4d05dc2d4f2 (patch)
tree1438f1fa5a3bdac0a8e772f210eb3b789b0fdeb0 /utils
parentbd5a3304c46730f42133b7d682bc88824e1fb69e (diff)
tmux: build fix: don't -I /usr/local/include
Tmux is forcing -I /usr/local/include on the compiler. Obviously, this is not good for cross compiles. God only knows why they put it here in the first place. Signed-off-by: Lawrence D'Anna <larry@elder-gods.org>
Diffstat (limited to 'utils')
-rw-r--r--utils/tmux/patches/200-usr-local.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/utils/tmux/patches/200-usr-local.patch b/utils/tmux/patches/200-usr-local.patch
new file mode 100644
index 000000000..07336deb8
--- /dev/null
+++ b/utils/tmux/patches/200-usr-local.patch
@@ -0,0 +1,14 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -101,9 +101,9 @@ bin_PROGRAMS = tmux$(EXEEXT)
+ @IS_DEBUG_TRUE@@IS_GCC_TRUE@ -Wdeclaration-after-statement
+ @IS_DEBUG_TRUE@@IS_GCC_TRUE@am__append_4 = -DDEBUG
+ @IS_DEBUG_FALSE@@IS_GCC_TRUE@am__append_5 = -O2
+-@IS_GCC4_TRUE@@IS_GCC_TRUE@am__append_6 = -iquote. -I/usr/local/include
++@IS_GCC4_TRUE@@IS_GCC_TRUE@am__append_6 = -iquote.
+ @IS_DEBUG_TRUE@@IS_GCC4_TRUE@@IS_GCC_TRUE@am__append_7 = -Wno-pointer-sign
+-@IS_GCC4_FALSE@@IS_GCC_TRUE@am__append_8 = -I. -I- -I/usr/local/include
++@IS_GCC4_FALSE@@IS_GCC_TRUE@am__append_8 = -I. -I-
+
+ # Set flags for Solaris.
+ @IS_GCC_TRUE@@IS_SUNOS_TRUE@am__append_9 = -D_XPG6 -D__EXTENSIONS__ -D_POSIX_PTHREAD_SEMANTICS